bef1592296
Drop 0001-add-cstdlib-header-to-ensure-EXIT_FAILURE-presence.patch since it's already upstream. Rebase shared/static build patches - these look unnecessary if we switch to cmake-package, however it seems to require the zmq package switches to cmake-package as well since static library naming looks different, which might be a problem for users. Also set the minimum required version of gcc to 4.7.x since the code now requires c++1x. Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
84 lines
2.5 KiB
Diff
84 lines
2.5 KiB
Diff
From 02ad67e60ef698ee47f6ee53b36e5b89c2fd71e7 Mon Sep 17 00:00:00 2001
|
|
From: =?UTF-8?q?J=C3=B6rg=20Krause?= <joerg.krause@embedded.rocks>
|
|
Date: Wed, 24 Feb 2016 10:07:11 -0300
|
|
Subject: [PATCH 1/2] Allow building shared or static library only
|
|
MIME-Version: 1.0
|
|
Content-Type: text/plain; charset=UTF-8
|
|
Content-Transfer-Encoding: 8bit
|
|
|
|
[Gustavo: update for 4.1.2]
|
|
|
|
Signed-off-by: Jörg Krause <joerg.krause@embedded.rocks>
|
|
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
|
|
---
|
|
Makefile | 19 +++++++++++++++----
|
|
1 file changed, 15 insertions(+), 4 deletions(-)
|
|
|
|
diff --git a/Makefile b/Makefile
|
|
index 9df5996..86c8fac 100644
|
|
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -79,6 +79,8 @@ ifeq ($(UNAME_S),Darwin)
|
|
endif
|
|
|
|
|
|
+BUILD_SHARED ?= yes
|
|
+
|
|
CONFIG_FLAGS =
|
|
ifeq ($(CONFIG),debug)
|
|
CONFIG_FLAGS = -g -fno-inline -ftemplate-depth-1000
|
|
@@ -93,13 +95,22 @@ ifneq (,$(findstring $(CONFIG),release loadtest))
|
|
CONFIG_FLAGS = -O3 -funroll-loops -ffast-math -finline-functions -fomit-frame-pointer -DNO_DEBUG_LOG -DNO_TRACE_LOG -DNDEBUG
|
|
endif
|
|
|
|
-COMMON_FLAGS = -MMD -std=c++11 -pipe -Wall -fPIC \
|
|
+COMMON_FLAGS = -MMD -std=c++11 -pipe -Wall \
|
|
-DBUILD_ENV=$(CONFIG) \
|
|
-DBUILD_DATESTAMP='$(APP_DATESTAMP)' \
|
|
-DBUILD_LIBRARY_NAME='"$(LIBRARY_NAME)"' \
|
|
-DBUILD_CLIENT_NAME='"$(CLIENT_TARGET)"' \
|
|
-I$(SRC_PATH) $(CUSTOM_INCLUDE_PATH)
|
|
|
|
+ifeq ($(BUILD_SHARED),yes)
|
|
+COMMON_FLAGS += -fPIC
|
|
+LIBRARY_TARGETS += $(LIBRARY_SHARED)
|
|
+endif
|
|
+
|
|
+ifeq ($(BUILD_STATIC),yes)
|
|
+LIBRARY_TARGETS += $(LIBRARY_ARCHIVE)
|
|
+endif
|
|
+
|
|
COMMON_LIBS = -lzmq
|
|
|
|
LIBRARY_LIBS =
|
|
@@ -147,10 +158,11 @@ install:
|
|
mkdir -p $(INCLUDEDIR)/$(LIBRARY_DIR)
|
|
mkdir -p $(LIBDIR)
|
|
install -m 644 $(ALL_LIBRARY_INCLUDES) $(INCLUDEDIR)/$(LIBRARY_DIR)
|
|
+ifeq ($(BUILD_SHARED),yes)
|
|
install -m 755 $(BUILD_PATH)/$(LIBRARY_VERSION_SHARED) $(LIBDIR)/$(LIBRARY_FULL_VERSION_SHARED)
|
|
- install -m 755 $(BUILD_PATH)/$(LIBRARY_ARCHIVE) $(LIBDIR)/$(LIBRARY_ARCHIVE)
|
|
ln -sf $(LIBRARY_FULL_VERSION_SHARED) $(LIBDIR)/$(LIBRARY_VERSION_SHARED)
|
|
ln -sf $(LIBRARY_FULL_VERSION_SHARED) $(LIBDIR)/$(LIBRARY_SHARED)
|
|
+endif
|
|
if [ -f $(BUILD_PATH)/$(CLIENT_TARGET) ]; then install -m 755 $(BUILD_PATH)/$(CLIENT_TARGET) $(BINDIR); fi
|
|
$(LDCONFIG)
|
|
@echo "use make installcheck to test the install"
|
|
@@ -172,7 +184,7 @@ clean:
|
|
|
|
client: $(CLIENT_TARGET)
|
|
|
|
-library: $(LIBRARY_SHARED) $(LIBRARY_ARCHIVE)
|
|
+library: $(LIBRARY_TARGETS)
|
|
|
|
#
|
|
# BUILD Targets
|
|
@@ -211,4 +223,3 @@ test: $(TESTS_TARGET)
|
|
$(OBJECT_PATH)/%.o: $(SRC_PATH)/%.cpp
|
|
-mkdir -p $(dir $@)
|
|
$(CXX) $(CPPFLAGS) $(CXXFLAGS) $(COMMON_FLAGS) $(CONFIG_FLAGS) -c -o $@ $<
|
|
-
|
|
--
|
|
2.4.10
|
|
|