kumquat-buildroot/package/augeas/0001-examples-Makefile-fix-missing-trailing-backslash-for-dump-LDADD.patch
Jörg Krause d2db5a6c5b augeas: bump to version 1.9.0
Add two patches from upstream to fix a build issue when building an
example. Ideally, the examples should not be build at all. However,
upstream disliked the idea of adding configure options like
`--disable-examples` [1]. So we'll make do with the patches and force a
autoreconf.

Additionaly, the signature was checked and a hash for the license file
is added.

[1] https://github.com/hercules-team/augeas/issues/535

Signed-off-by: Jörg Krause <joerg.krause@embedded.rocks>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
2018-01-15 21:17:52 +01:00

26 lines
902 B
Diff

From d506cf6c1567cbb0a762c04d9354ab1694a5ac05 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?J=C3=B6rg=20Krause?= <joerg.krause@embedded.rocks>
Date: Mon, 11 Dec 2017 23:33:08 +0100
Subject: [PATCH] Update Makefile.am
Add missing trailing backslash for `dump_LDADD`.
Backported from: d506cf6c1567cbb0a762c04d9354ab1694a5ac05
Signed-off-by: Jörg Krause <joerg.krause@embedded.rocks>
---
examples/Makefile.am | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/examples/Makefile.am b/examples/Makefile.am
index 66ebcdf2..a19597bf 100644
--- a/examples/Makefile.am
+++ b/examples/Makefile.am
@@ -13,5 +13,5 @@ fadot_LDADD = $(top_builddir)/src/libfa.la $(GNULIB)
dump_sources = dump.c
dump_LDFLAGS = -static
-dump_LDADD = $(top_builddir)/src/libaugeas.la $(top_builddir)/src/libfa.la
+dump_LDADD = $(top_builddir)/src/libaugeas.la $(top_builddir)/src/libfa.la \
$(GNULIB)