bfbe4dd19e
Drop some patches: - glibc 2.17 and 2.18 are now supported by upstream - coregrind/link_tool_exe_linux.in has been reworked and should now support ccache [Peter: drop unneeded AUTORECONF as configure.in no longer gets patched] Signed-off-by: Jérôme Pouiller <jezz@sysmic.org> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
33 lines
894 B
Diff
33 lines
894 B
Diff
From 872ade34d6af973ca88d5accd9e819216ecb94ba Mon Sep 17 00:00:00 2001
|
|
From: Pierre Habouzit <madcoder@debian.org>
|
|
Date: Tue, 10 May 2011 23:11:45 +0200
|
|
Subject: [PATCH 1/3] workaround SIGSEGV on PPC.
|
|
MIME-Version: 1.0
|
|
Content-Type: text/plain; charset=UTF-8
|
|
Content-Transfer-Encoding: 8bit
|
|
|
|
Signed-off-by: Pierre Habouzit <madcoder@debian.org>
|
|
Signed-off-by: Jérôme Pouiller <jezz@sysmic.org>
|
|
---
|
|
coregrind/m_machine.c | 4 ++++
|
|
1 file changed, 4 insertions(+)
|
|
|
|
diff --git a/coregrind/m_machine.c b/coregrind/m_machine.c
|
|
index 28a180e..8426551 100644
|
|
--- a/coregrind/m_machine.c
|
|
+++ b/coregrind/m_machine.c
|
|
@@ -27,6 +27,10 @@
|
|
The GNU General Public License is contained in the file COPYING.
|
|
*/
|
|
|
|
+#ifdef __powerpc__
|
|
+# pragma GCC optimize ("-O0")
|
|
+#endif
|
|
+
|
|
#include "pub_core_basics.h"
|
|
#include "pub_core_vki.h"
|
|
#include "pub_core_libcsetjmp.h" // setjmp facilities
|
|
--
|
|
1.8.3.2
|
|
|