2455c89bab
This is mostly a mechanical bump, with a refresh of all the patches to accomodate the offsets, and some minor conflict resolution. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
25 lines
757 B
Diff
25 lines
757 B
Diff
Add an option to disable the zlib module
|
|
|
|
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
---
|
|
configure.in | 6 ++++++
|
|
1 file changed, 6 insertions(+)
|
|
|
|
Index: Python-2.7.2/configure.in
|
|
===================================================================
|
|
--- Python-2.7.2.orig/configure.in
|
|
+++ Python-2.7.2/configure.in
|
|
@@ -2448,6 +2448,12 @@
|
|
DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} bz2"
|
|
fi])
|
|
|
|
+AC_ARG_ENABLE(zlib,
|
|
+ AS_HELP_STRING([--disable-zlib], [disable ZLIB]),
|
|
+ [ if test "$enableval" = "no"; then
|
|
+ DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} zlib"
|
|
+ fi])
|
|
+
|
|
AC_ARG_ENABLE(dbm,
|
|
AS_HELP_STRING([--disable-dbm], [disable DBM]),
|
|
[ if test "$enableval" = "no"; then
|