2455c89bab
This is mostly a mechanical bump, with a refresh of all the patches to accomodate the offsets, and some minor conflict resolution. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
26 lines
761 B
Diff
26 lines
761 B
Diff
Add an option to disable CJK codecs
|
|
|
|
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
|
|
---
|
|
configure.in | 6 ++++++
|
|
1 file changed, 6 insertions(+)
|
|
|
|
Index: Python-2.7.2/configure.in
|
|
===================================================================
|
|
--- Python-2.7.2.orig/configure.in
|
|
+++ Python-2.7.2/configure.in
|
|
@@ -2424,6 +2424,12 @@
|
|
DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} _sqlite3"
|
|
fi
|
|
|
|
+AC_ARG_ENABLE(codecs-cjk,
|
|
+ AS_HELP_STRING([--disable-codecs-cjk], [disable CJK codecs]),
|
|
+ [ if test "$enableval" = "no"; then
|
|
+ DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} _codecs_kr _codecs_jp _codecs_cn _codecs_tw _codecs_hk"
|
|
+ fi])
|
|
+
|
|
AC_SUBST(TK)
|
|
AC_ARG_ENABLE(tk,
|
|
AS_HELP_STRING([--disable-tk], [disable tk]),
|