2455c89bab
This is mostly a mechanical bump, with a refresh of all the patches to accomodate the offsets, and some minor conflict resolution. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
54 lines
1.3 KiB
Diff
54 lines
1.3 KiB
Diff
Add an option to disable the curses module
|
|
|
|
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
|
|
---
|
|
Makefile.pre.in | 6 +++++-
|
|
configure.in | 9 +++++++++
|
|
2 files changed, 14 insertions(+), 1 deletion(-)
|
|
|
|
Index: Python-2.7.2/Makefile.pre.in
|
|
===================================================================
|
|
--- Python-2.7.2.orig/Makefile.pre.in
|
|
+++ Python-2.7.2/Makefile.pre.in
|
|
@@ -867,7 +867,7 @@
|
|
multiprocessing multiprocessing/dummy \
|
|
unittest \
|
|
lib-old \
|
|
- curses $(MACHDEPS)
|
|
+ $(MACHDEPS)
|
|
|
|
ifeq (@TEST_MODULES@,yes)
|
|
LIBSUBDIRS += test test/data \
|
|
@@ -906,6 +906,10 @@
|
|
endif
|
|
endif
|
|
|
|
+ifeq (@CURSES@,yes)
|
|
+LIBSUBDIRS += curses
|
|
+endif
|
|
+
|
|
libinstall: build_all $(srcdir)/Lib/$(PLATDIR)
|
|
@for i in $(SCRIPTDIR) $(LIBDEST); \
|
|
do \
|
|
Index: Python-2.7.2/configure.in
|
|
===================================================================
|
|
--- Python-2.7.2.orig/configure.in
|
|
+++ Python-2.7.2/configure.in
|
|
@@ -2425,6 +2425,15 @@
|
|
DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} _tkinter"
|
|
fi
|
|
|
|
+AC_SUBST(CURSES)
|
|
+AC_ARG_ENABLE(curses,
|
|
+ AS_HELP_STRING([--disable-curses], [disable curses]),
|
|
+ [ CURSES="${enableval}" ], [ CURSES=yes ])
|
|
+
|
|
+if test "$CURSES" = "no"; then
|
|
+ DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} _curses _curses_panel"
|
|
+fi
|
|
+
|
|
AC_SUBST(PYDOC)
|
|
|
|
AC_ARG_ENABLE(pydoc,
|