6364139385
Examples do not compile for a static build, because libtool forcibly wants to link against the shared version of libstdc++.so, instead of the static version. Since we do not really need the examples on the target, just disable them, it is easier than fixing libtool. Also, while we're at it, rename the patches to include a sequence number. Fixes: http://autobuild.buildroot.org/results/66e/66e19cfd5a6048d2aaa46365518ea875e0abcb4d/ http://autobuild.buildroot.org/results/71d/71d9ba50b41efa05a3aff06c24412d5e8b81d8f1/ [Thomas: edit commit log to indicate that the patches are renamed to include a sequence number.] Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
21 lines
751 B
Diff
21 lines
751 B
Diff
Properly link libfcgi++ against libfcgi
|
|
|
|
We cannot directly use -lfcgi to link libfcgi++ against libfcgi,
|
|
because libfcgi is not installed at this time. Instead, we should rely
|
|
on libtool doing the right thing, by specifying libfcgi.la in
|
|
libfcgi++ LIBADD variable.
|
|
|
|
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
|
|
Index: b/libfcgi/Makefile.am
|
|
===================================================================
|
|
--- a/libfcgi/Makefile.am
|
|
+++ b/libfcgi/Makefile.am
|
|
@@ -23,5 +23,6 @@
|
|
$(INCLUDEDIR)/fcgio.h \
|
|
fcgio.cpp
|
|
libfcgi___la_CFLAGS = @PTHREAD_CFLAGS@
|
|
-libfcgi___la_LDFLAGS = -lfcgi -rpath @libdir@
|
|
+libfcgi___la_LIBADD = libfcgi.la
|
|
+libfcgi___la_LDFLAGS = -rpath @libdir@
|