6898144768
Drop 0001-dont-use-fshort-wchar-when-building.patch and 0003-Remove-extra-const-keywords-gcc-7-gripes-about.patch as they are now upstream. The upstream repo moved to the 'rhboot' github project, so adjust upstream URL in .mk and help text to match. Version 15 introduces build time configuration of the default EFI directory (E.G. the subdirectory in the EFI system partition where the loader is installed). This used to be hardcoded to redhat, but now a value must be specified at build time. Given that, it is unlikely that people relied on the default value so set it to the more sensible 'buildroot'. While we are at it, also add a hash for the license file. Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
41 lines
974 B
Diff
41 lines
974 B
Diff
From bbfcc60497c326576bb23cb01d90115ef3cf6947 Mon Sep 17 00:00:00 2001
|
|
From: Andy Shevchenko <andriy.shevchenko@linux.intel.com>
|
|
Date: Fri, 25 Nov 2016 20:26:52 +0200
|
|
Subject: [PATCH] Remove unneeded <uchar.h> include
|
|
|
|
This fixes the build with uClibc.
|
|
|
|
Signed-off-by: Andy Shevchenko <andriy.shevchenko@linux.intel.com>
|
|
---
|
|
src/efibootdump.c | 1 -
|
|
src/eficonman.c | 1 -
|
|
2 files changed, 2 deletions(-)
|
|
|
|
diff --git a/src/efibootdump.c b/src/efibootdump.c
|
|
index 6ff8360..7c5a1c5 100644
|
|
--- a/src/efibootdump.c
|
|
+++ b/src/efibootdump.c
|
|
@@ -19,7 +19,6 @@
|
|
#include <stdint.h>
|
|
#include <stdio.h>
|
|
#include <stdlib.h>
|
|
-#include <uchar.h>
|
|
#include <unistd.h>
|
|
|
|
#include "error.h"
|
|
diff --git a/src/eficonman.c b/src/eficonman.c
|
|
index 2c2be38..9bfae79 100644
|
|
--- a/src/eficonman.c
|
|
+++ b/src/eficonman.c
|
|
@@ -17,7 +17,6 @@
|
|
#include <stdint.h>
|
|
#include <stdio.h>
|
|
#include <stdlib.h>
|
|
-#include <uchar.h>
|
|
#include <unistd.h>
|
|
|
|
#define _(String) gettext (String)
|
|
--
|
|
2.10.2
|
|
|