e2c03d54bb
This reverts commit 233202597d
, which
causes a lot of build failures. Part of the Python build process tries
to use os.replace(), which is only available since Python 3.3. It
should work if the host-python being built was used, but unfortunately
the system Python ends up being used, causing the build failure.
Fixes:
http://autobuild.buildroot.net/results/ed95a7ded6bd6c17bd0820b3a96862487b71eb2b/
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
63 lines
2.2 KiB
Diff
63 lines
2.2 KiB
Diff
From 0870559b9af82b55f1fd8b35528510f563577256 Mon Sep 17 00:00:00 2001
|
|
From: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
Date: Wed, 23 Dec 2015 11:51:31 +0100
|
|
Subject: [PATCH] Add an option to disable decimal
|
|
|
|
This patch replaces the existing --with-system-libmpdec option with a
|
|
--with-libmpdec={system,builtin,none} option, which allows to tell
|
|
Python whether we want to use the system libmpdec (already installed),
|
|
the libmpdec builtin the Python sources, or no libmpdec at all.
|
|
|
|
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
---
|
|
configure.ac | 17 ++++++++++++-----
|
|
setup.py | 2 +-
|
|
2 files changed, 13 insertions(+), 6 deletions(-)
|
|
|
|
diff --git a/configure.ac b/configure.ac
|
|
index 2699e7ceb1..e2c3b6f25c 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -2862,13 +2862,20 @@ AC_SUBST(LIBFFI_INCLUDEDIR)
|
|
AC_MSG_RESULT($with_system_ffi)
|
|
|
|
# Check for use of the system libmpdec library
|
|
-AC_MSG_CHECKING(for --with-system-libmpdec)
|
|
-AC_ARG_WITH(system_libmpdec,
|
|
- AS_HELP_STRING([--with-system-libmpdec], [build _decimal module using an installed libmpdec library]),
|
|
+AC_MSG_CHECKING(for --with-libmpdec)
|
|
+AC_ARG_WITH(libmpdec,
|
|
+ AS_HELP_STRING([--with-libmpdec], [select which libmpdec version to use: system, builtin, none]),
|
|
[],
|
|
- [with_system_libmpdec="no"])
|
|
+ [with_libmpdec="builtin"])
|
|
|
|
-AC_MSG_RESULT($with_system_libmpdec)
|
|
+AC_MSG_RESULT($with_libmpdec)
|
|
+if test "$with_libmpdec" != "none"; then
|
|
+ MPDEC=yes
|
|
+else
|
|
+ DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} _decimal"
|
|
+ MPDEC=no
|
|
+fi
|
|
+AC_SUBST(MPDEC)
|
|
|
|
# Check for support for loadable sqlite extensions
|
|
AC_MSG_CHECKING(for --enable-loadable-sqlite-extensions)
|
|
diff --git a/setup.py b/setup.py
|
|
index d642825c1e..5b98255857 100644
|
|
--- a/setup.py
|
|
+++ b/setup.py
|
|
@@ -2058,7 +2058,7 @@ class PyBuildExt(build_ext):
|
|
def _decimal_ext(self):
|
|
extra_compile_args = []
|
|
undef_macros = []
|
|
- if '--with-system-libmpdec' in sysconfig.get_config_var("CONFIG_ARGS"):
|
|
+ if '--with-libmpdec=system' in sysconfig.get_config_var("CONFIG_ARGS"):
|
|
include_dirs = []
|
|
libraries = [':libmpdec.so.2']
|
|
sources = ['_decimal/_decimal.c']
|
|
--
|
|
2.13.5
|
|
|