6520762932
Now that the cpython project has a nice Github repository, with tags, it's much nicer to handle the stack of Python patches with Git. The python3 package patches had already been converted, but not the python package patches. Therefore, this commit does the move. There is no functional change, only reformatting of the patches. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Reviewed-by: Yegor Yefremov <yegorslists@googlemail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
42 lines
1.6 KiB
Diff
42 lines
1.6 KiB
Diff
From bddfcbb8a4c011ca2fe471f7a4124cd64b5b0f00 Mon Sep 17 00:00:00 2001
|
|
From: Samuel Martin <s.martin49@gmail.com>
|
|
Date: Tue, 7 Mar 2017 22:23:58 +0100
|
|
Subject: [PATCH] Remove the python symlink install rules
|
|
|
|
The python symlink installation will be handled by Buildroot itself,
|
|
because Buildroot needs to control to what python interpreter (python2
|
|
or python3) the python symlink points to.
|
|
|
|
Signed-off-by: Samuel Martin <s.martin49@gmail.com>
|
|
[Bernd: rebased against version 2.7.12.]
|
|
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
|
|
---
|
|
Makefile.pre.in | 7 -------
|
|
1 file changed, 7 deletions(-)
|
|
|
|
diff --git a/Makefile.pre.in b/Makefile.pre.in
|
|
index beb0837..dedcf61 100644
|
|
--- a/Makefile.pre.in
|
|
+++ b/Makefile.pre.in
|
|
@@ -968,17 +968,10 @@ bininstall: altbininstall
|
|
echo "Creating directory $(LIBPC)"; \
|
|
$(INSTALL) -d -m $(DIRMODE) $(DESTDIR)$(LIBPC); \
|
|
fi
|
|
- -if test -f $(DESTDIR)$(BINDIR)/$(PYTHON) -o -h $(DESTDIR)$(BINDIR)/$(PYTHON); \
|
|
- then rm -f $(DESTDIR)$(BINDIR)/$(PYTHON); \
|
|
- else true; \
|
|
- fi
|
|
- (cd $(DESTDIR)$(BINDIR); $(LN) -s python2$(EXE) $(PYTHON))
|
|
-rm -f $(DESTDIR)$(BINDIR)/python2$(EXE)
|
|
(cd $(DESTDIR)$(BINDIR); $(LN) -s python$(VERSION)$(EXE) python2$(EXE))
|
|
-rm -f $(DESTDIR)$(BINDIR)/python2-config
|
|
(cd $(DESTDIR)$(BINDIR); $(LN) -s python$(VERSION)-config python2-config)
|
|
- -rm -f $(DESTDIR)$(BINDIR)/python-config
|
|
- (cd $(DESTDIR)$(BINDIR); $(LN) -s python2-config python-config)
|
|
-test -d $(DESTDIR)$(LIBPC) || $(INSTALL) -d -m $(DIRMODE) $(DESTDIR)$(LIBPC)
|
|
-rm -f $(DESTDIR)$(LIBPC)/python2.pc
|
|
(cd $(DESTDIR)$(LIBPC); $(LN) -s python-$(VERSION).pc python2.pc)
|
|
--
|
|
2.7.4
|
|
|