05fb9bd165
By default the 'make install' step for qt5base will strip all the binaries and libraries when they are installed to staging. This hinders debugging as the libraries in staging dir have been stripped and is unnecessary as buildroot will strip all files on the target Signed-off-by: Will Wagner <will_wagner@carallon.com> Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Reviewed-by: Fatih Aşıcı <fatih.asici@gmail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
36 lines
1.3 KiB
Diff
36 lines
1.3 KiB
Diff
Add a Buildroot 'device' to ease cross-compilation
|
|
|
|
Qt5 has a mechanism to support "device" profiles, so that people can
|
|
specify the compiler, compiler flags and so on for a specific device.
|
|
|
|
We leverage this mechanism in the Buildroot packaging of qt5 to
|
|
simplify cross-compilation: we have our own "device" definition, which
|
|
allows us to easily pass the cross-compiler paths and flags from our
|
|
qt5.mk.
|
|
|
|
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
|
|
Index: b/mkspecs/devices/linux-buildroot-g++/qmake.conf
|
|
===================================================================
|
|
--- /dev/null
|
|
+++ b/mkspecs/devices/linux-buildroot-g++/qmake.conf
|
|
@@ -0,0 +1,12 @@
|
|
+include(../common/linux_device_pre.conf)
|
|
+
|
|
+#modifications to gcc-base.conf
|
|
+QMAKE_CFLAGS += $${BR_COMPILER_CFLAGS}
|
|
+QMAKE_CXXFLAGS += $${BR_COMPILER_CXXFLAGS}
|
|
+QMAKE_CXXFLAGS_RELEASE += -O3
|
|
+CONFIG += nostrip
|
|
+
|
|
+QMAKE_LIBS += -lrt -lpthread -ldl
|
|
+
|
|
+include(../common/linux_device_post.conf)
|
|
+load(qt_config)
|
|
Index: b/mkspecs/devices/linux-buildroot-g++/qplatformdefs.h
|
|
===================================================================
|
|
--- /dev/null
|
|
+++ b/mkspecs/devices/linux-buildroot-g++/qplatformdefs.h
|
|
@@ -0,0 +1 @@
|
|
+#include "../../linux-g++/qplatformdefs.h"
|