6a16e1631f
I re-did the patches: one patch per change, patch configure.in instead of the configure script itself, a few more issues fixed. This should hopefully make the patches acceptable for upstream, or at least make it easier to migrate them on version bumps. This also fixes compilation with musl libc. Signed-off-by: Maarten ter Huurne <maarten@treewalker.org> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
124 lines
3.7 KiB
Diff
124 lines
3.7 KiB
Diff
From: Maarten ter Huurne <maarten@treewalker.org>
|
|
Date: Sat, 13 Sep 2014 12:04:41 +0200
|
|
Subject: Provide cross compilation alternatives for all AC_TRY_RUN uses
|
|
|
|
Signed-off-by: Maarten ter Huurne <maarten@treewalker.org>
|
|
---
|
|
configure.in | 30 +++++++++++++++++++-----------
|
|
1 file changed, 19 insertions(+), 11 deletions(-)
|
|
|
|
diff --git a/configure.in b/configure.in
|
|
index ff9606d..d53a079 100644
|
|
--- a/configure.in
|
|
+++ b/configure.in
|
|
@@ -347,7 +347,8 @@ main()
|
|
exit(0);
|
|
}
|
|
], AC_NOTE(- your fifos are usable) fifo=1,
|
|
-AC_NOTE(- your fifos are not usable))
|
|
+AC_NOTE(- your fifos are not usable),
|
|
+AC_NOTE(- skipping check because we are cross compiling; assuming fifos are usable) fifo=1)
|
|
rm -f /tmp/conftest*
|
|
|
|
if test -n "$fifo"; then
|
|
@@ -395,7 +396,8 @@ main()
|
|
exit(0);
|
|
}
|
|
], AC_NOTE(- your implementation is ok),
|
|
-AC_NOTE(- you have a broken implementation) AC_DEFINE(BROKEN_PIPE) fifobr=1)
|
|
+AC_NOTE(- you have a broken implementation) AC_DEFINE(BROKEN_PIPE) fifobr=1,
|
|
+AC_NOTE(- skipping check because we are cross compiling; assuming fifo implementation is ok))
|
|
rm -f /tmp/conftest*
|
|
fi
|
|
|
|
@@ -457,7 +459,8 @@ main()
|
|
exit(0);
|
|
}
|
|
], AC_NOTE(- your sockets are usable) sock=1,
|
|
-AC_NOTE(- your sockets are not usable))
|
|
+AC_NOTE(- your sockets are not usable),
|
|
+AC_NOTE(- skipping check because we are cross compiling; assuming sockets are usable) sock=1)
|
|
rm -f /tmp/conftest*
|
|
|
|
if test -n "$sock"; then
|
|
@@ -496,7 +499,8 @@ main()
|
|
}
|
|
],AC_NOTE(- you are normal),
|
|
AC_NOTE(- unix domain sockets are not kept in the filesystem)
|
|
-AC_DEFINE(SOCK_NOT_IN_FS) socknofs=1)
|
|
+AC_DEFINE(SOCK_NOT_IN_FS) socknofs=1,
|
|
+AC_NOTE(- skipping check because we are cross compiling; assuming sockets are normal))
|
|
rm -f /tmp/conftest*
|
|
fi
|
|
|
|
@@ -623,7 +627,8 @@ main()
|
|
exit(0);
|
|
}
|
|
],AC_NOTE(- select is ok),
|
|
-AC_NOTE(- select can't count) AC_DEFINE(SELECT_BROKEN))
|
|
+AC_NOTE(- select can't count) AC_DEFINE(SELECT_BROKEN),
|
|
+AC_NOTE(- skipping check because we are cross compiling; assuming select is ok))
|
|
|
|
dnl
|
|
dnl **** termcap or terminfo ****
|
|
@@ -665,7 +670,8 @@ main()
|
|
{
|
|
exit(strcmp(tgoto("%p1%d", 0, 1), "1") ? 0 : 1);
|
|
}], AC_NOTE(- you use the termcap database),
|
|
-AC_NOTE(- you use the terminfo database) AC_DEFINE(TERMINFO))
|
|
+AC_NOTE(- you use the terminfo database) AC_DEFINE(TERMINFO),
|
|
+AC_NOTE(- skipping check because we are cross compiling; assuming terminfo database is used) AC_DEFINE(TERMINFO))
|
|
AC_CHECKING(ospeed)
|
|
AC_TRY_LINK(extern short ospeed;,ospeed=5;,,AC_DEFINE(NEED_OSPEED))
|
|
|
|
@@ -800,7 +806,8 @@ main()
|
|
else
|
|
AC_NOTE(- can't determine - assume ptys are world accessable)
|
|
fi
|
|
- ]
|
|
+ ],
|
|
+ AC_NOTE(- skipping check because we are cross compiling; assuming ptys are world accessable)
|
|
)
|
|
rm -f conftest_grp
|
|
fi
|
|
@@ -884,7 +891,7 @@ AC_EGREP_CPP(yes,
|
|
#endif
|
|
], load=1)
|
|
fi
|
|
-if test -z "$load" ; then
|
|
+if test -z "$load" && test "$cross_compiling" = no ; then
|
|
AC_CHECKING(for kernelfile)
|
|
for core in /unix /vmunix /dynix /hp-ux /xelos /dev/ksyms /kernel/unix /kernel/genunix /unicos /mach /netbsd /386bsd /dgux /bsd /stand/vmunix; do
|
|
if test -f $core || test -c $core; then
|
|
@@ -1077,7 +1084,7 @@ main()
|
|
#endif
|
|
exit(0);
|
|
}
|
|
-],,AC_DEFINE(SYSVSIGS))
|
|
+],,AC_DEFINE(SYSVSIGS),:)
|
|
|
|
fi
|
|
|
|
@@ -1157,7 +1164,7 @@ main() {
|
|
if (strncmp(buf, "cdedef", 6))
|
|
exit(1);
|
|
exit(0); /* libc version works properly. */
|
|
-}], AC_DEFINE(USEBCOPY))
|
|
+}], AC_DEFINE(USEBCOPY),,:)
|
|
|
|
AC_TRY_RUN([
|
|
#define bcopy(s,d,l) memmove(d,s,l)
|
|
@@ -1172,7 +1179,8 @@ main() {
|
|
if (strncmp(buf, "cdedef", 6))
|
|
exit(1);
|
|
exit(0); /* libc version works properly. */
|
|
-}], AC_DEFINE(USEMEMMOVE))
|
|
+}], AC_DEFINE(USEMEMMOVE),,
|
|
+ AC_NOTE(- skipping check because we are cross compiling; use memmove) AC_DEFINE(USEMEMMOVE))
|
|
|
|
AC_SYS_LONG_FILE_NAMES
|
|
|
|
--
|
|
1.8.4.5
|
|
|