kumquat-buildroot/package/x11r7/xlib_libXt/xlib_libXt-1.0.6-cross-compile-fix.patch
Thomas Petazzoni 90a459ce4d xorg: add a new cross-compile fix for libXt 1.0.6
The cross-compile fix included in mainline of libXt between 1.0.5 and
1.0.6 is not sufficient. It allows to pass a different compiler for
the host tools, but still uses the TARGET_CFLAGS/TARGET_LDFLAGS to
compile the host tools, which obviously isn't correct.

The new patch allows to use the CFLAGS_FOR_BUILD/LDFLAGS_FOR_BUILD
variables as the CFLAGS/LDFLAGS to build the host tools.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
2009-07-28 11:53:04 +02:00

29 lines
693 B
Diff

diff --git a/configure.ac b/configure.ac
index 043ab5f..cb00a41 100755
--- a/configure.ac
+++ b/configure.ac
@@ -48,6 +48,10 @@ if test x"$CC_FOR_BUILD" = x; then
fi
fi
AC_SUBST([CC_FOR_BUILD])
+CFLAGS_FOR_BUILD=${CFLAGS_FOR_BUILD-${CFLAGS}}
+AC_SUBST(CFLAGS_FOR_BUILD)
+LDFLAGS_FOR_BUILD=${LDFLAGS_FOR_BUILD-${LDFLAGS}}
+AC_SUBST(LDFLAGS_FOR_BUILD)
PKG_CHECK_MODULES(XT, sm x11 xproto kbproto)
diff --git a/util/Makefile.am b/util/Makefile.am
index 0d3ff01..37b78d2 100644
--- a/util/Makefile.am
+++ b/util/Makefile.am
@@ -5,6 +5,8 @@ noinst_PROGRAMS = makestrs
endif
CC = @CC_FOR_BUILD@
+CFLAGS = @CFLAGS_FOR_BUILD@
+LDFLAGS = @LDFLAGS_FOR_BUILD@
EXTRA_DIST = \
Shell.ht \