fd4abc30d2
Removed patch 0004, applied upstream. Renumbered remaining patches. Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
32 lines
1.2 KiB
Diff
32 lines
1.2 KiB
Diff
From 6515c423f9e6b8b607678a260a16db2684d88a4e Mon Sep 17 00:00:00 2001
|
|
From: Bernd Kuhls <bernd.kuhls@t-online.de>
|
|
Date: Tue, 1 May 2018 22:30:09 +0200
|
|
Subject: [PATCH] Don't hardcode the name of the vorbis and ogg libraries
|
|
|
|
Fixes linking error with tremor due to wrong library name.
|
|
|
|
Downloaded from Gentoo package
|
|
https://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/media-video/vlc/files/vlc-2.1.0-fix-libtremor-libs.patch?view=markup
|
|
|
|
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
|
|
---
|
|
modules/codec/Makefile.am | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/modules/codec/Makefile.am b/modules/codec/Makefile.am
|
|
index 10132a92f3..2fb52a586e 100644
|
|
--- a/modules/codec/Makefile.am
|
|
+++ b/modules/codec/Makefile.am
|
|
@@ -324,7 +324,7 @@ codec_LTLIBRARIES += $(LTLIBdaala)
|
|
libtremor_plugin_la_SOURCES = codec/vorbis.c
|
|
libtremor_plugin_la_CPPFLAGS = $(AM_CPPFLAGS) -DMODULE_NAME_IS_tremor
|
|
libtremor_plugin_la_LDFLAGS = $(AM_LDFLAGS) -rpath '$(codecdir)'
|
|
-libtremor_plugin_la_LIBADD = -lvorbisdec -logg
|
|
+libtremor_plugin_la_LIBADD = $(VORBIS_LIBS) $(OGG_LIBS)
|
|
EXTRA_LTLIBRARIES += libtremor_plugin.la
|
|
codec_LTLIBRARIES += $(LTLIBtremor)
|
|
|
|
--
|
|
2.14.4
|
|
|