9868d24190
The psmisc-no-__progname.patch removes the usage of __progname, which removes any difference between pstree and pstree.x11. Therefore, we make sure to not create the pstree.x11 symbolic link in the target. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
48 lines
1.6 KiB
Diff
48 lines
1.6 KiB
Diff
[PATCH]: pstree: don't use glibc-specific __progname
|
|
|
|
uclibc (per default) doesn't implement __progname, and the pstree.x11
|
|
stuff isn't that critical, so just disable it.
|
|
|
|
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
|
|
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
|
|
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
|
|
Index: psmisc-22.13/src/pstree.c
|
|
===================================================================
|
|
--- psmisc-22.13.orig/src/pstree.c 2010-07-12 13:10:03.000000000 +0200
|
|
+++ psmisc-22.13/src/pstree.c 2011-05-21 16:33:37.456530775 +0200
|
|
@@ -49,8 +49,6 @@
|
|
#include <selinux/selinux.h>
|
|
#endif /*WITH_SELINUX */
|
|
|
|
-extern const char *__progname;
|
|
-
|
|
#define PROC_BASE "/proc"
|
|
|
|
/* UTF-8 defines by Johan Myreen, updated by Ben Winslow */
|
|
@@ -854,9 +852,6 @@
|
|
textdomain(PACKAGE);
|
|
#endif
|
|
|
|
- if (!strcmp(__progname, "pstree.x11"))
|
|
- wait_end = 1;
|
|
-
|
|
/*
|
|
* Attempt to figure out a good default symbol set. Will be overriden by
|
|
* command-line options, if given.
|
|
Index: psmisc-22.13/src/Makefile.in
|
|
===================================================================
|
|
--- psmisc-22.13.orig/src/Makefile.in 2011-05-21 16:33:42.748530777 +0200
|
|
+++ psmisc-22.13/src/Makefile.in 2011-05-21 16:33:47.360530782 +0200
|
|
@@ -557,10 +557,6 @@
|
|
grep '^{ 1,"HUP" },$$' signames.h >/dev/null || \
|
|
{ rm -f signames.h; exit 1; }
|
|
|
|
-install-exec-hook:
|
|
- cd $(DESTDIR)$(bindir) && \
|
|
- ( [ -h pstree.x11 ] || $(LN_S) pstree pstree.x11)
|
|
-
|
|
# Tell versions [3.59,3.63) of GNU make to not export all variables.
|
|
# Otherwise a system limit (for SysV at least) may be exceeded.
|
|
.NOEXPORT:
|