6a16e1631f
I re-did the patches: one patch per change, patch configure.in instead of the configure script itself, a few more issues fixed. This should hopefully make the patches acceptable for upstream, or at least make it easier to migrate them on version bumps. This also fixes compilation with musl libc. Signed-off-by: Maarten ter Huurne <maarten@treewalker.org> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
32 lines
1002 B
Diff
32 lines
1002 B
Diff
From: Maarten ter Huurne <maarten@treewalker.org>
|
|
Date: Mon, 15 Sep 2014 00:06:20 +0200
|
|
Subject: Support overriding SCREEN to get a non-versioned binary
|
|
|
|
If a packager runs "make install SCREEN=screen", do not create
|
|
"screen" as a symlink to itself.
|
|
|
|
Signed-off-by: Maarten ter Huurne <maarten@treewalker.org>
|
|
---
|
|
Makefile.in | 2 ++
|
|
1 file changed, 2 insertions(+)
|
|
|
|
diff --git a/Makefile.in b/Makefile.in
|
|
index 3c12fdb..860f351 100644
|
|
--- a/Makefile.in
|
|
+++ b/Makefile.in
|
|
@@ -86,9 +86,11 @@ install_bin: .version screen
|
|
$(INSTALL_PROGRAM) screen $(DESTDIR)$(bindir)/$(SCREEN)
|
|
-chown root $(DESTDIR)$(bindir)/$(SCREEN)
|
|
-chmod 4755 $(DESTDIR)$(bindir)/$(SCREEN)
|
|
+ifneq (${SCREEN},screen)
|
|
# This doesn't work if $(bindir)/screen is a symlink
|
|
rm -f $(DESTDIR)$(bindir)/screen
|
|
(cd $(DESTDIR)$(bindir) && ln -f -s $(SCREEN) screen)
|
|
+endif
|
|
cp $(srcdir)/utf8encodings/?? $(DESTDIR)$(SCREENENCODINGS)
|
|
|
|
###############################################################################
|
|
--
|
|
1.8.4.5
|
|
|