6a16e1631f
I re-did the patches: one patch per change, patch configure.in instead of the configure script itself, a few more issues fixed. This should hopefully make the patches acceptable for upstream, or at least make it easier to migrate them on version bumps. This also fixes compilation with musl libc. Signed-off-by: Maarten ter Huurne <maarten@treewalker.org> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
30 lines
970 B
Diff
30 lines
970 B
Diff
From: Maarten ter Huurne <maarten@treewalker.org>
|
|
Date: Mon, 15 Sep 2014 00:03:05 +0200
|
|
Subject: Change binary permission flags even if chown fails
|
|
|
|
Typically when creating a package, the build is not run as root, so
|
|
the chown will fail. But the chmod can still be done.
|
|
|
|
Signed-off-by: Maarten ter Huurne <maarten@treewalker.org>
|
|
---
|
|
Makefile.in | 3 ++-
|
|
1 file changed, 2 insertions(+), 1 deletion(-)
|
|
|
|
diff --git a/Makefile.in b/Makefile.in
|
|
index 65549e9..3c12fdb 100644
|
|
--- a/Makefile.in
|
|
+++ b/Makefile.in
|
|
@@ -84,7 +84,8 @@ screen: $(OFILES)
|
|
|
|
install_bin: .version screen
|
|
$(INSTALL_PROGRAM) screen $(DESTDIR)$(bindir)/$(SCREEN)
|
|
- -chown root $(DESTDIR)$(bindir)/$(SCREEN) && chmod 4755 $(DESTDIR)$(bindir)/$(SCREEN)
|
|
+ -chown root $(DESTDIR)$(bindir)/$(SCREEN)
|
|
+ -chmod 4755 $(DESTDIR)$(bindir)/$(SCREEN)
|
|
# This doesn't work if $(bindir)/screen is a symlink
|
|
rm -f $(DESTDIR)$(bindir)/screen
|
|
(cd $(DESTDIR)$(bindir) && ln -f -s $(SCREEN) screen)
|
|
--
|
|
1.8.4.5
|
|
|