beb49d882e
[Thomas: use libpthsem instead of pth, remove !uclibc dependency, minor formatting fixes in the .mk file.] Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com> Reviewed-by: Markos Chandras <Markos.Chandras@imgtec.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
28 lines
1.0 KiB
Diff
28 lines
1.0 KiB
Diff
Fix usage of PTH_CONFIG to work with pthsem
|
|
|
|
The pthsem re-implement of pth provides a compatibility layer for pth,
|
|
but its pth-config script behaves slightly differently than the
|
|
original one when reporting the version number. This patch to gnupg2's
|
|
configure script adjusts the version checking to support this
|
|
difference, since Buildroot uses pth-config from pthsem.
|
|
|
|
We patch directly the configure script, because triggering the entire
|
|
autoreconf dance for just a one byte change in the configure script
|
|
seems a bit silly.
|
|
|
|
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
|
|
Index: b/configure
|
|
===================================================================
|
|
--- a/configure
|
|
+++ b/configure
|
|
@@ -8346,7 +8346,7 @@
|
|
tmp=1.3.7
|
|
if test "$PTH_CONFIG" != "no"; then
|
|
|
|
- _pth_version=`$PTH_CONFIG --version | awk 'NR==1 {print $3}'`
|
|
+ _pth_version=`$PTH_CONFIG --version | awk 'NR==1 {print $2}'`
|
|
_req_version="$tmp"
|
|
|
|
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for PTH - version >= $_req_version" >&5
|