63aeae6538
This refreshes the set of python3 patches so they apply cleanly on the v3.5.2 tag of cpython Github repository. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Reviewed-by: Yegor Yefremov <yegorslists@googlemail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
72 lines
1.9 KiB
Diff
72 lines
1.9 KiB
Diff
From 61f201afe59bbfbb1094d987fd74ac9cd4764d52 Mon Sep 17 00:00:00 2001
|
|
From: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
Date: Wed, 23 Dec 2015 11:49:14 +0100
|
|
Subject: [PATCH] Add an option to disable the tk module
|
|
|
|
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
Signed-off-by: Samuel Martin <s.martin49@gmail.com>
|
|
---
|
|
Makefile.pre.in | 11 ++++++++---
|
|
configure.ac | 9 +++++++++
|
|
2 files changed, 17 insertions(+), 3 deletions(-)
|
|
|
|
diff --git a/Makefile.pre.in b/Makefile.pre.in
|
|
index d262c04..851faa3 100644
|
|
--- a/Makefile.pre.in
|
|
+++ b/Makefile.pre.in
|
|
@@ -1196,7 +1196,7 @@ maninstall: altmaninstall
|
|
PLATDIR= @PLATDIR@
|
|
MACHDEPS= $(PLATDIR)
|
|
XMLLIBSUBDIRS= xml xml/dom xml/etree xml/parsers xml/sax
|
|
-LIBSUBDIRS= tkinter \
|
|
+LIBSUBDIRS= \
|
|
site-packages \
|
|
asyncio \
|
|
collections concurrent concurrent/futures encodings \
|
|
@@ -1214,8 +1214,7 @@ LIBSUBDIRS= tkinter \
|
|
venv venv/scripts venv/scripts/posix \
|
|
curses $(MACHDEPS)
|
|
|
|
-TESTSUBDIRS = tkinter/test tkinter/test/test_tkinter tkinter/test/test_ttk \
|
|
- test test/test_asyncio \
|
|
+TESTSUBDIRS = test test/test_asyncio \
|
|
test/test_email test/test_email/data \
|
|
test/test_json \
|
|
test/audiodata \
|
|
@@ -1274,6 +1273,12 @@ LIBSUBDIRS += sqlite3
|
|
TESTSUBDIRS += sqlite3/test
|
|
endif
|
|
|
|
+ifeq (@TK@,yes)
|
|
+LIBSUBDIRS += tkinter
|
|
+TESTSUBDIRS += tkinter/test tkinter/test/test_tkinter \
|
|
+ tkinter/test/test_ttk
|
|
+endif
|
|
+
|
|
ifeq (@TEST_MODULES@,yes)
|
|
LIBSUBDIRS += $(TESTSUBDIRS)
|
|
endif
|
|
diff --git a/configure.ac b/configure.ac
|
|
index c9d0912..d5047ec 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -2985,6 +2985,15 @@ if test "$SQLITE3" = "no" ; then
|
|
DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} _sqlite3"
|
|
fi
|
|
|
|
+AC_SUBST(TK)
|
|
+AC_ARG_ENABLE(tk,
|
|
+ AS_HELP_STRING([--disable-tk], [disable tk]),
|
|
+ [ TK="${enableval}" ], [ TK=yes ])
|
|
+
|
|
+if test "$TK" = "no"; then
|
|
+ DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} _tkinter"
|
|
+fi
|
|
+
|
|
AC_SUBST(PYDOC)
|
|
|
|
AC_ARG_ENABLE(pydoc,
|
|
--
|
|
2.7.4
|
|
|