bb79b96472
Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
41 lines
1.7 KiB
Diff
41 lines
1.7 KiB
Diff
[PATCH] configure.in: use correct directfb-config in version check
|
|
|
|
The configure script has just checked for the correct directfb-config
|
|
script, so also use it for the version check instead of whatever
|
|
might be in the path.
|
|
|
|
Also patch the generated configure, as it doesn't cleanly autoreconf.
|
|
|
|
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
|
|
---
|
|
configure | 2 +-
|
|
configure.in | 2 +-
|
|
2 files changed, 2 insertions(+), 2 deletions(-)
|
|
|
|
Index: SDL-1.2.15/configure.in
|
|
===================================================================
|
|
--- SDL-1.2.15.orig/configure.in
|
|
+++ SDL-1.2.15/configure.in
|
|
@@ -1276,7 +1276,7 @@
|
|
else
|
|
set -- `echo $DIRECTFB_REQUIRED_VERSION | sed 's/\./ /g'`
|
|
NEED_VERSION=`expr $1 \* 10000 + $2 \* 100 + $3`
|
|
- set -- `directfb-config --version | sed 's/\./ /g'`
|
|
+ set -- `$DIRECTFBCONFIG --version | sed 's/\./ /g'`
|
|
HAVE_VERSION=`expr $1 \* 10000 + $2 \* 100 + $3`
|
|
if test $HAVE_VERSION -ge $NEED_VERSION; then
|
|
DIRECTFB_CFLAGS=`$DIRECTFBCONFIG --cflags`
|
|
Index: SDL-1.2.15/configure
|
|
===================================================================
|
|
--- SDL-1.2.15.orig/configure
|
|
+++ SDL-1.2.15/configure
|
|
@@ -24958,7 +24958,7 @@
|
|
else
|
|
set -- `echo $DIRECTFB_REQUIRED_VERSION | sed 's/\./ /g'`
|
|
NEED_VERSION=`expr $1 \* 10000 + $2 \* 100 + $3`
|
|
- set -- `directfb-config --version | sed 's/\./ /g'`
|
|
+ set -- `$DIRECTFBCONFIG --version | sed 's/\./ /g'`
|
|
HAVE_VERSION=`expr $1 \* 10000 + $2 \* 100 + $3`
|
|
if test $HAVE_VERSION -ge $NEED_VERSION; then
|
|
DIRECTFB_CFLAGS=`$DIRECTFBCONFIG --cflags`
|