kumquat-buildroot/package/tesseract-ocr/0002-configure.ac-fix-build-on-aarch64_be.patch
Fabrice Fontaine f0a96f7364 package/tesseract-ocr: fix aarch64_be build
Fix the following aarch64_be build failure probably raised since the
addition of the package:

/home/buildroot/autobuild/instance-3/output-1/host/opt/ext-toolchain/bin/../lib/gcc/aarch64_be-none-linux-gnu/10.3.1/../../../../aarch64_be-none-linux-gnu/bin/ld: ./.libs/libtesseract.so: undefined reference to `tesseract::IntSimdMatrix::intSimdMatrixNEON'

Fixes:
 - http://autobuild.buildroot.org/results/b9246a37fcf6be4fabfc491daddadfb09e0a320a

Update the comment about _AUTORECONF=YES, list the two patches since
both touch configure.ac

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
[yann.morin.1998@free.fr: upsdate comment about _AUTORECONF=YES]
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
2022-08-21 13:38:29 +02:00

33 lines
1.2 KiB
Diff

From cffb8a36a987cd0d013d73501dd20c553ff69c77 Mon Sep 17 00:00:00 2001
From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Date: Sun, 21 Aug 2022 10:21:43 +0200
Subject: [PATCH] configure.ac: fix build on aarch64_be
Fix the following build failure on aarch64_be:
/home/buildroot/autobuild/instance-3/output-1/host/opt/ext-toolchain/bin/../lib/gcc/aarch64_be-none-linux-gnu/10.3.1/../../../../aarch64_be-none-linux-gnu/bin/ld: ./.libs/libtesseract.so: undefined reference to `tesseract::IntSimdMatrix::intSimdMatrixNEON'
Fixes:
- http://autobuild.buildroot.org/results/b9246a37fcf6be4fabfc491daddadfb09e0a320a
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
[Retrieved (and backported) from:
https://github.com/tesseract-ocr/tesseract/commit/cffb8a36a987cd0d013d73501dd20c553ff69c77]
---
configure.ac | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/configure.ac b/configure.ac
index 63579c954f..2b05052395 100644
--- a/configure.ac
+++ b/configure.ac
@@ -170,7 +170,7 @@ case "${host_cpu}" in
;;
- aarch64)
+ aarch64*)
# ARMv8 always has NEON and does not need special compiler flags.
AM_CONDITIONAL([HAVE_NEON], true)