d632d42b34
i386 (limited to 64 bit long double... same as double), arm (libfloat), mips, and mipsel. Enable cross compiling a native gcc 3.3 toolchain to run on the target. Misc rootfs cleanups... strip some things that weren't, eliminate duplicate libs, move openssl shared libs out of /lib, reduce size of libssl.so by dynamicly linking with libcrypto.so, fix dropbear compile on mips.
15 lines
656 B
Diff
15 lines
656 B
Diff
--- gcc-3.3.2/libstdc++-v3/testsuite/Makefile.in.dist 2003-10-26 00:07:43.000000000 -0500
|
|
+++ gcc-3.3.2/libstdc++-v3/testsuite/Makefile.in 2003-10-26 00:06:35.000000000 -0500
|
|
@@ -204,9 +204,9 @@
|
|
PROGRAMS = $(noinst_PROGRAMS)
|
|
|
|
abi_check_OBJECTS = abi_check.$(OBJEXT)
|
|
-abi_check_LDADD = $(LDADD)
|
|
+abi_check_LDADD = -lstdc++ $(LDADD)
|
|
abi_check_DEPENDENCIES =
|
|
-abi_check_LDFLAGS =
|
|
+abi_check_LDFLAGS = -L../src
|
|
CXXFLAGS = @CXXFLAGS@
|
|
CXXCOMPILE = $(CXX) $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CXXFLAGS) $(CXXFLAGS)
|
|
LTCXXCOMPILE = $(LIBTOOL) --mode=compile $(CXX) $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CXXFLAGS) $(CXXFLAGS)
|