kumquat-buildroot/package/multimedia/tremor/tremor-export-all-symbols.patch
Sven Neumann 989565d305 tremor: add patch to export all symbols
Tremor comes with a Version_script file that limits the
list of exported symbols. Without these symbols we can't
build the ivorbisdec GStreamer plug-in (and probably other
application). This commit adds a patch that removes this
limitation and makes all global symbols available.

Signed-off-by: Sven Neumann <s.neumann@raumfeld.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
2009-12-08 21:49:55 +01:00

33 lines
836 B
Diff

--- tremor-16259-orig/configure.in 2009-12-02 11:45:11.000000000 +0100
+++ tremor-16259/configure.in 2009-12-03 16:50:19.000000000 +0100
@@ -72,23 +72,6 @@
LDFLAGS="$LDFLAGS $ldflags_save"
-# Test whenever ld supports -version-script
-AC_PROG_LD
-AC_PROG_LD_GNU
-if test "x$lt_cv_prog_gnu_ld" = "xyes"; then
- SHLIB_VERSION_ARG="Wl,--version-script=Version_script"
-
- dnl Set extra linker options
- case "$target_os" in
- linux* | solaris* )
- SHLIB_VERSION_ARG="-Wl,--version-script=Version_script"
- ;;
- *)
- ;;
- esac
- LDFLAGS="$LDFLAGS $SHLIB_VERSION_ARG"
-fi
-
dnl --------------------------------------------------
dnl Options
dnl --------------------------------------------------
@@ -128,4 +111,4 @@
AC_SUBST(DEBUG)
AC_SUBST(PROFILE)
-AC_OUTPUT(Makefile Version_script)
+AC_OUTPUT(Makefile)