0c15169f5a
Removed all patches, they are now included in this release. Added other patches fixing errors. Removed option BR2_PACKAGE_PPPD_RADIUS, upstream build system, now auto- conf-based, does not support disabling the radius plugin. Removed BR2_PACKAGE_PPPD_OVERWRITE_RESOLV_CONF, upstream now defaults to /etc, quoting README: "Note that if you have built and installed previous versions of this package and you want to continue having configuration and TDB files in /etc/ppp, you will need to use the --sysconfdir option to ./configure." Switched build system to autoconf, added optional systemd support. Added configure option to enable multilink support which now defaults to false but was enabled before: https://github.com/ppp-project/ppp/blob/2.4.9/pppd/Makefile.linux#L57 Signed-off-by: Bernd Kuhls <bernd@kuhls.net> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
57 lines
1.6 KiB
Diff
57 lines
1.6 KiB
Diff
From 7f89208b860ea0c41636410bfdb6a609b2772f47 Mon Sep 17 00:00:00 2001
|
|
From: Eivind Naess <eivnaes@yahoo.com>
|
|
Date: Sun, 23 Apr 2023 11:37:01 -0700
|
|
Subject: [PATCH] Closes #411, Fixing up parsing in radiusclient.conf
|
|
|
|
Adding curly braces to fix the code.
|
|
|
|
Signed-off-by: Eivind Naess <eivnaes@yahoo.com>
|
|
|
|
Upstream: https://github.com/ppp-project/ppp/commit/7f89208b860ea0c41636410bfdb6a609b2772f47
|
|
|
|
Signed-off-by: Bernd Kuhls <bernd@kuhls.net>
|
|
---
|
|
pppd/plugins/radius/config.c | 12 ++++++++----
|
|
1 file changed, 8 insertions(+), 4 deletions(-)
|
|
|
|
diff --git a/pppd/plugins/radius/config.c b/pppd/plugins/radius/config.c
|
|
index 39744fc..e1a4814 100644
|
|
--- a/pppd/plugins/radius/config.c
|
|
+++ b/pppd/plugins/radius/config.c
|
|
@@ -235,24 +235,28 @@ int rc_read_config(char *filename)
|
|
|
|
switch (option->type) {
|
|
case OT_STR:
|
|
- if (set_option_str(filename, line, option, p) < 0)
|
|
+ if (set_option_str(filename, line, option, p) < 0) {
|
|
fclose(configfd);
|
|
return (-1);
|
|
+ }
|
|
break;
|
|
case OT_INT:
|
|
- if (set_option_int(filename, line, option, p) < 0)
|
|
+ if (set_option_int(filename, line, option, p) < 0) {
|
|
fclose(configfd);
|
|
return (-1);
|
|
+ }
|
|
break;
|
|
case OT_SRV:
|
|
- if (set_option_srv(filename, line, option, p) < 0)
|
|
+ if (set_option_srv(filename, line, option, p) < 0) {
|
|
fclose(configfd);
|
|
return (-1);
|
|
+ }
|
|
break;
|
|
case OT_AUO:
|
|
- if (set_option_auo(filename, line, option, p) < 0)
|
|
+ if (set_option_auo(filename, line, option, p) < 0) {
|
|
fclose(configfd);
|
|
return (-1);
|
|
+ }
|
|
break;
|
|
default:
|
|
fatal("rc_read_config: impossible case branch!");
|
|
--
|
|
2.39.2
|
|
|