Fixes: - CVE-2017-9233 - External entity infinite loop DoS. See: https://libexpat.github.io/doc/cve-2017-9233/ - CVE-2016-9063 -- Detect integer overflow And further more: - Fix regression from fix to CVE-2016-0718 cutting off longer tag names. - Extend fix for CVE-2016-5300 (use getrandom() if available). - Extend fix for CVE-2012-0876 (Change hash algorithm to William Ahern's version of SipHash). Also add an upstream patch to fix detection of getrandom(). Signed-off-by: Peter Korsgaard <peter@korsgaard.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
30 lines
873 B
Diff
30 lines
873 B
Diff
From 602e6c78ca750c082b72f8cdf4a38839b312959f Mon Sep 17 00:00:00 2001
|
|
From: Sebastian Pipping <sebastian@pipping.org>
|
|
Date: Sun, 18 Jun 2017 18:55:10 +0200
|
|
Subject: [PATCH] configure.ac: Fix mis-detection of getrandom on Debian
|
|
GNU/kFreeBSD (#50)
|
|
|
|
There is no such thing but we need to link (not just compile) to realize.
|
|
|
|
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
|
|
---
|
|
expat/configure.ac | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/expat/configure.ac b/expat/configure.ac
|
|
index 1357c9a..444c002 100644
|
|
--- a/expat/configure.ac
|
|
+++ b/expat/configure.ac
|
|
@@ -130,7 +130,7 @@ AC_LINK_IFELSE([AC_LANG_SOURCE([
|
|
|
|
|
|
AC_MSG_CHECKING([for getrandom (Linux 3.17+, glibc 2.25+)])
|
|
-AC_COMPILE_IFELSE([AC_LANG_SOURCE([
|
|
+AC_LINK_IFELSE([AC_LANG_SOURCE([
|
|
#include <stdlib.h> /* for NULL */
|
|
#include <sys/random.h>
|
|
int main() {
|
|
--
|
|
2.11.0
|
|
|