131995ff5a
Currently, the target and host flex packages do not behave the same in terms of patching: the target variant has a patch hook that disables building the programs (because they are not needed, and do not build on no-MMU platforms). However, this hook is obviously not executed for host-flex, because we really want the host flex binary to be built. In preparation for the introduction of out-of-tree package build, it is important that we don't do different things in the patch hooks for the target and host variant of a given package, because the source tree will be shared between the target and host builds. To solve this, we introduce a --disable-program configure option, through a patch to the flex configure.ac and Makefile.am. This patch makes the current 0001-flex-disable-documentation.patch no longer needed. Furthermore, building the documentation is a PITA: flex.1 depends on configure.ac and a few other files generated during the build. Touching flex.1 does not work, because automake will forcibly remove the files when its prerequisites are too old, so pre-requisites of flex.1 will always be more recent than flex.1. So, we add a patch that adds a --disable-doc configure option. Fixes: http://autobuild.buildroot.org/results/f70/f70b39632535bb9692d0a032166b2f4104532967/ http://autobuild.buildroot.org/results/525/52567afdfe7992b3518de0e01227ba14aa300f21/ [...] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> [yann.morin.1998@free.fr: - rebase on-top of master, - add patch to not build the documentation, because simply touching flex.1 is no longer enough. - keep install in target/, for shared builds ] Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Cc: Adrian Perez de Castro <aperez@igalia.com> Cc: Arnout Vandecappelle <arnout@mind.be> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
36 lines
1.1 KiB
Diff
36 lines
1.1 KiB
Diff
From ffa886a580929f26fd5e5a40c9c5334955c48553 Mon Sep 17 00:00:00 2001
|
|
From: Explorer09 <explorer09@gmail.com>
|
|
Date: Mon, 4 Sep 2017 10:47:33 +0800
|
|
Subject: [PATCH] build: AC_USE_SYSTEM_EXTENSIONS in configure.ac.
|
|
|
|
This would, e.g. define _GNU_SOURCE in config.h, enabling the
|
|
reallocarray() prototype in glibc 2.26+ on Linux systems with that
|
|
version of glibc.
|
|
|
|
Fixes #241.
|
|
|
|
Backported from: 24fd0551333e7eded87b64dd36062da3df2f6380
|
|
Signed-off-by: Adrian Perez de Castro <aperez@igalia.com>
|
|
---
|
|
configure.ac | 2 ++
|
|
1 file changed, 2 insertions(+)
|
|
|
|
diff --git a/configure.ac b/configure.ac
|
|
index 55e774b..c879fe1 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -25,8 +25,10 @@
|
|
# autoconf requirements and initialization
|
|
|
|
AC_INIT([the fast lexical analyser generator],[2.6.4],[flex-help@lists.sourceforge.net],[flex])
|
|
+AC_PREREQ([2.60])
|
|
AC_CONFIG_SRCDIR([src/scan.l])
|
|
AC_CONFIG_AUX_DIR([build-aux])
|
|
+AC_USE_SYSTEM_EXTENSIONS
|
|
LT_INIT
|
|
AM_INIT_AUTOMAKE([1.11.3 -Wno-portability foreign check-news std-options dist-lzip parallel-tests subdir-objects])
|
|
AC_CONFIG_HEADER([src/config.h])
|
|
--
|
|
2.14.1
|
|
|