b989436447
While the official upstream has not published any new tarball, they have continued to update their Subversion repository with additional changes. This commit therefore updates the vpnc package to a newer version, using the Github repository that replicates the original Subversion repository. Since the update required some updates to the patches, we took this opportunity to split them in more fine-grained changes, and document them more properly. Consequently: - The patch 0001 that fixes the Makefile gets split into 3 patches, 0001, 0002 and 0003, each for one specific issue. - Patch 0002 to disable building the manpages gets changed into a solution that is potentially upstreamable, and is now patch 0004. - A new patch 0005 is added to specify a custom libgcrypt-config path, since this tool is now used to know how to link with libgcrypt. - The SUSv3 function removal patch is now patch 0006, and gains a better commit log. Also, this vpnc version now depends on gnutls, which basically is a better replacement for OpenSSL, whose support was not enabled by default due to licensing issues (vpnc is under the GPL, which isn't compatible with the OpenSSL license). Patches have been submitted upstream: http://lists.unix-ag.uni-kl.de/pipermail/vpnc-devel/2016-June/004186.html Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
46 lines
1.5 KiB
Diff
46 lines
1.5 KiB
Diff
From 014a8e04a0fa775b2ade78e5f7655a1453375884 Mon Sep 17 00:00:00 2001
|
|
From: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
Date: Wed, 10 Feb 2016 23:31:12 +0100
|
|
Subject: [PATCH] Makefile: allow passing custom CFLAGS/CPPFLAGS
|
|
|
|
vpnc's Makefile specifies some CFLAGS and CPPFLAGS value, but it may
|
|
be needed to pass additional custom flags on the make command line. To
|
|
make this possible, we switch from a plain += operator to the
|
|
"override ... +=" operator.
|
|
|
|
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
---
|
|
|
|
Makefile | 8 ++++----
|
|
1 file changed, 4 insertions(+), 4 deletions(-)
|
|
|
|
diff --git a/Makefile b/Makefile
|
|
index e80ef17..7ac225a 100644
|
|
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -62,9 +62,9 @@ RELEASE_VERSION := $(shell cat VERSION)
|
|
|
|
CC ?= gcc
|
|
CFLAGS ?= -O3 -g
|
|
-CFLAGS += -W -Wall -Wmissing-declarations -Wwrite-strings
|
|
-CFLAGS += $(shell libgcrypt-config --cflags) $(CRYPTO_CFLAGS)
|
|
-CPPFLAGS += -DVERSION=\"$(VERSION)\"
|
|
+override CFLAGS += -W -Wall -Wmissing-declarations -Wwrite-strings
|
|
+override CFLAGS += $(shell libgcrypt-config --cflags) $(CRYPTO_CFLAGS)
|
|
+override CPPFLAGS += -DVERSION=\"$(VERSION)\"
|
|
LDFLAGS ?= -g
|
|
LIBS += $(shell libgcrypt-config --libs) $(CRYPTO_LDADD)
|
|
|
|
@@ -73,7 +73,7 @@ LIBS += -lnsl -lresolv -lsocket
|
|
endif
|
|
ifneq (,$(findstring Apple,$(shell $(CC) --version)))
|
|
# enabled in FSF GCC, disabled by default in Apple GCC
|
|
-CFLAGS += -fstrict-aliasing -freorder-blocks -fsched-interblock
|
|
+override CFLAGS += -fstrict-aliasing -freorder-blocks -fsched-interblock
|
|
endif
|
|
|
|
all : $(BINS) vpnc.8
|
|
--
|
|
2.6.4
|
|
|