22b0c44eb6
Fixes: CVE-2014-8321 - gps_tracer stack overflow CVE-2014-8322 - tcp_test length parameter inconsistency CVE-2014-8323 - buddy-ng missing check in data format CVE-2014-8324 - net_get missing check for invalid values Previous CVE patch dropped since the fix is upstream. Also add hash file. Drop iw runtime dep since it's only one of many required by airmon-zc (a script) which require a ton of conditionals for just that tool. It will tell somewhat nicely if they're missing. These would be: awk - from busybox or gawk ethtool grep - from busybox or grep ip or ifconfig - from busybox, iproute2 or net-tools iw lspci - from pciutils (needs full variant) lsusb - from usbutils (needs full variant) modprobe/modinfo - from busybox or kmod uname - from busybox or coreutils [Peter: drop double -lpthread from sqlite conditional] Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
34 lines
1.1 KiB
Diff
34 lines
1.1 KiB
Diff
From 1abf7a6aad3d7931de2c01b578f62986b75de2f5 Mon Sep 17 00:00:00 2001
|
|
From: Gustavo Zacarias <gustavo@zacarias.com.ar>
|
|
Date: Tue, 11 Nov 2014 16:23:42 -0300
|
|
Subject: [PATCH] Optionally use LIBPCAP for required libpcap libraries
|
|
|
|
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
|
|
---
|
|
Status: Reported http://trac.aircrack-ng.org/ticket/1528
|
|
|
|
diff --git a/src/Makefile b/src/Makefile
|
|
index 14350b6..7bd4271 100644
|
|
--- a/src/Makefile
|
|
+++ b/src/Makefile
|
|
@@ -23,6 +23,7 @@ ifneq ($(OSNAME), cygwin) #There is yet no libpcap support for windows, so we sk
|
|
HAVE_PCAP = $(shell ld -lpcap 2> /dev/null && echo yes)
|
|
ifeq ($(HAVE_PCAP), yes) #cannot link with -lpcap, skip crawler
|
|
BINFILES += besside-ng-crawler$(EXE)
|
|
+ LIBPCAP = -lpcap
|
|
endif
|
|
endif
|
|
|
|
@@ -168,7 +169,7 @@ besside-ng$(EXE): $(OBJS_BS) $(LIBOSD)
|
|
$(CC) $(CFLAGS) $(LDFLAGS) $(OBJS_BS) -o $(@) $(LIBS) $(LIBSSL) -lz $(LIBPCRE)
|
|
|
|
besside-ng-crawler$(EXE): $(OBJS_BC)
|
|
- $(CC) $(CFLAGS) $(LDFLAGS) $(OBJS_BC) -o $(@) -lpcap
|
|
+ $(CC) $(CFLAGS) $(LDFLAGS) $(OBJS_BC) -o $(@) $(LIBPCAP)
|
|
|
|
makeivs-ng$(EXE): $(OBJS_MI)
|
|
$(CC) $(CFLAGS) $(LDFLAGS) $(OBJS_MI) -o $(@) $(LDFLAGS)
|
|
--
|
|
2.0.4
|
|
|