kumquat-buildroot/package/midori/0001-disable-vala-fatal-warnings.patch
Adam Duskett 42f19d49fb package/midori: bump to version 9.0
This is a substantial update as the last time the midori version was bumped
was on Fri Apr 29 2016 commit 54bbd88b1f.

Changes:

package/Config.in: Move midori out of the "X applications" submenu and into
the "Graphic applications" submenu, as it is not dependent on X.

- Drop the two existing patches as they no longer apply.
- 0001-disable-vala-fatal-warnings.patch: new patch. This patch fixes
  errors when building midori in a buildroot source repository that is also
  a git project.

- 0002-add-option-to-specify-path-to-g-ir-compiler.patchL new patch.
  This patch introduces a new option that allows the make system to specify
  a path to the g-ir-compiler, or else the host path's g-ir-compiler is used
  which results in failed builds.

- Change the site to the github repository, as that is where the latest
  releases are published.

- New dependencies: gobject-introspection, json-glib, libarchive, and libpeas.
- gcr is no longer an optional dependency.
- host-python3 is now a mandatory dependency.

Signed-off-by: Adam Duskett <aduskett@gmail.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
2021-11-23 00:06:24 +01:00

31 lines
1022 B
Diff

From be91b1260d3215119e4ab5b19012ab80d6ff788d Mon Sep 17 00:00:00 2001
From: Adam Duskett <aduskett@gmail.com>
Date: Mon, 11 Oct 2021 16:58:34 -0700
Subject: [PATCH] disable vala fatal warnings
When building midori in a buildroot directory cloned from git, the git
descript --tags command return tags from buildroot, which in turn sets
the --fatal-warnings flag. Disable --fatal-warnings unconditionally.
Signed-off-by: Adam Duskett <aduskett@gmail.com>
---
CMakeLists.txt | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8e72f08..39941e2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -18,7 +18,7 @@ execute_process(COMMAND "git" "describe" "--tags"
if (REVISION)
set(CORE_VERSION "${REVISION}")
# All warnings are errors in development builds
- set(VALAFLAGS ${VALAFLAGS} --fatal-warnings)
+ set(VALAFLAGS ${VALAFLAGS} --disable-assert)
else ()
# No runtime type checks
set(VALAFLAGS ${VALAFLAGS} --disable-assert)
--
2.30.2