41ff126ac1
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
30 lines
816 B
Diff
30 lines
816 B
Diff
Fix parallel build
|
|
|
|
https://bugs.gentoo.org/673390
|
|
|
|
Downloaded from
|
|
https://gitweb.gentoo.org/repo/gentoo.git/tree/net-libs/daq/files/daq-2.0.6-parallel-grammar.patch
|
|
|
|
Patch was sent upstream: https://seclists.org/snort/2014/q3/1016
|
|
|
|
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
|
|
|
|
--- a/sfbpf/Makefile.am
|
|
+++ b/sfbpf/Makefile.am
|
|
@@ -43,13 +43,14 @@
|
|
libsfbpf_la_LDFLAGS = -version-info 0:1:0 @XCCFLAGS@
|
|
|
|
# use of $@ and $< here is a GNU idiom that borks BSD
|
|
-sf_scanner.c: $(srcdir)/scanner.l
|
|
+sf_scanner.c: $(srcdir)/scanner.l tokdefs.h
|
|
@rm -f $(srcdir)/sf_scanner.c
|
|
$(srcdir)/runlex.sh $(V_LEX) -osf_scanner.c $(srcdir)/scanner.l
|
|
|
|
sf_scanner.o: sf_scanner.c tokdefs.h
|
|
|
|
tokdefs.h: sf_grammar.c
|
|
+
|
|
sf_grammar.c: $(srcdir)/grammar.y
|
|
@rm -f sf_grammar.c tokdefs.h
|
|
$(V_YACC) -d $(srcdir)/grammar.y
|