e7115551c4
setools is no longer hosted on https://github.com/TresysTechnology/setools/. Update the source location to its new home, https://github.com/SELinuxProject/setools/. Refresh patches 0001-remove-werror-flag-from-setup.patch and 0002-Do-not-export-use-setools.InfoFlowAnalysis-and-setoo.patch for 4.3.0 and remove patch 0003-setup.py-drop-path-prefix-from-man-install.patch that is now upstream. Add a new dependency on host-python-cython, as setup.py now depends on it. Signed-off-by: Antoine Tenart <antoine.tenart@bootlin.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
32 lines
1.2 KiB
Diff
32 lines
1.2 KiB
Diff
From 8ab5a49247d870d92a8287db6134877ebf7a4379 Mon Sep 17 00:00:00 2001
|
|
From: Adam Duskett <aduskett@gmail.com>
|
|
Date: Thu, 12 Oct 2017 22:04:58 -0400
|
|
Subject: [PATCH] remove werror flag from setup
|
|
|
|
Compilers older than gcc6 will generate uninitialized variable warnings which
|
|
will cause compiling to fail.
|
|
|
|
Signed-off-by: Antoine Tenart <antoine.tenart@bootlin.com>
|
|
[Refreshed for 4.3.0]
|
|
Signed-off-by: Adam Duskett <aduskett@gmail.com>
|
|
---
|
|
setup.py | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/setup.py b/setup.py
|
|
index 457c83049ca5..4dcb30196abf 100644
|
|
--- a/setup.py
|
|
+++ b/setup.py
|
|
@@ -106,7 +106,7 @@ ext_py_mods = [Extension('setools.policyrep', ['setools/policyrep.pyx'],
|
|
libraries=['selinux', 'sepol'],
|
|
library_dirs=lib_dirs,
|
|
define_macros=macros,
|
|
- extra_compile_args=['-Werror', '-Wextra',
|
|
+ extra_compile_args=['-Wextra',
|
|
'-Waggregate-return',
|
|
'-Wfloat-equal',
|
|
'-Wformat', '-Wformat=2',
|
|
--
|
|
2.26.2
|
|
|