f8d0d28bf9
- Rebase patches from 2.25 on top of 2.26. - Use git format for patches - remove upstreamed xtensa patches The first patch [1] is needed to be able to build glibc with binutils 2.26 on nios2. The second from [2] fix an assertion issue with ld. [1] https://sourceware.org/git/gitweb.cgi?p=binutils-gdb.git;a=commitdiff;h=a7be2893a6449e64fe6cfcdd8700b0a367a69f19 [2] https://sourceware.org/bugzilla/show_bug.cgi?id=19405 Signed-off-by: Romain Naour <romain.naour@gmail.com> Cc: Gustavo Zacarias <gustavo@zacarias.com.ar> Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Cc: Max Filippov <jcmvbkbc@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
42 lines
1.3 KiB
Diff
42 lines
1.3 KiB
Diff
From d76a7549b43974fe8564971a3f40459bc495a8a7 Mon Sep 17 00:00:00 2001
|
|
From: Romain Naour <romain.naour@gmail.com>
|
|
Date: Fri, 25 Dec 2015 11:40:53 +0100
|
|
Subject: [PATCH] ld-makefile
|
|
|
|
[Romain: rebase on top of 2.26]
|
|
Signed-off-by: Romain Naour <romain.naour@gmail.com>
|
|
---
|
|
ld/Makefile.am | 2 +-
|
|
ld/Makefile.in | 2 +-
|
|
2 files changed, 2 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/ld/Makefile.am b/ld/Makefile.am
|
|
index 0b3b049..3871c74 100644
|
|
--- a/ld/Makefile.am
|
|
+++ b/ld/Makefile.am
|
|
@@ -57,7 +57,7 @@ endif
|
|
# We put the scripts in the directory $(scriptdir)/ldscripts.
|
|
# We can't put the scripts in $(datadir) because the SEARCH_DIR
|
|
# directives need to be different for native and cross linkers.
|
|
-scriptdir = $(tooldir)/lib
|
|
+scriptdir = $(libdir)
|
|
|
|
EMUL = @EMUL@
|
|
EMULATION_OFILES = @EMULATION_OFILES@
|
|
diff --git a/ld/Makefile.in b/ld/Makefile.in
|
|
index ed98f87..530e4c9 100644
|
|
--- a/ld/Makefile.in
|
|
+++ b/ld/Makefile.in
|
|
@@ -413,7 +413,7 @@ AM_CFLAGS = $(WARN_CFLAGS) $(ELF_CLFAGS)
|
|
# We put the scripts in the directory $(scriptdir)/ldscripts.
|
|
# We can't put the scripts in $(datadir) because the SEARCH_DIR
|
|
# directives need to be different for native and cross linkers.
|
|
-scriptdir = $(tooldir)/lib
|
|
+scriptdir = $(libdir)
|
|
BASEDIR = $(srcdir)/..
|
|
BFDDIR = $(BASEDIR)/bfd
|
|
INCDIR = $(BASEDIR)/include
|
|
--
|
|
2.4.3
|
|
|