f0335b0cf7
Drop the po/ disable patch; not needed anymore. Drop the __mempcpy compatibility patch; __mempcpy is not used anymore. Refresh the -Werror removal patch; still needed, unfortunately. Renumber the remaining patches. Add GPLv3 license file. Add license files hash. [Peter: drop security reference, was added post-release] Cc: Stefan Fröberg <stefan.froberg@petroprogram.com> Signed-off-by: Baruch Siach <baruch@tkos.co.il> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
63 lines
2.0 KiB
Diff
63 lines
2.0 KiB
Diff
From dfea82b761b2ea4708fbf9370a5467ae4be525ca Mon Sep 17 00:00:00 2001
|
|
From: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
Date: Mon, 29 May 2017 23:03:48 +0300
|
|
Subject: [PATCH] Add a --{enable,disable}-progs configure option
|
|
|
|
Add a --{enable,disable}-progs configuration option to elfutils. This
|
|
allows to selectively disable the compilation of the elfutils programs
|
|
(in which case only the libraries are built and installed). This is
|
|
useful because the programs are often not needed, and also because
|
|
building the programs against uClibc causes several issues (lack of
|
|
obstack_printf() in uClibc for example).
|
|
|
|
Based on the former patch by Thomas Petazzoni.
|
|
|
|
[Vincent: tweak patch for 0.166]
|
|
|
|
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
|
|
---
|
|
Makefile.am | 6 +++++-
|
|
configure.ac | 6 ++++++
|
|
2 files changed, 11 insertions(+), 1 deletion(-)
|
|
|
|
diff --git a/Makefile.am b/Makefile.am
|
|
index 2ff444e7bf1d..70443abb4fb6 100644
|
|
--- a/Makefile.am
|
|
+++ b/Makefile.am
|
|
@@ -26,9 +26,13 @@ AM_MAKEFLAGS = --no-print-directory
|
|
|
|
pkginclude_HEADERS = version.h
|
|
|
|
+if ENABLE_PROGS
|
|
+PROGS_SUBDIR = src
|
|
+endif
|
|
+
|
|
# Add doc back when we have some real content.
|
|
SUBDIRS = config m4 lib libelf libebl libdwelf libdwfl libdw libcpu libasm \
|
|
- backends src po tests
|
|
+ backends $(PROGS_SUBDIR) po tests
|
|
|
|
EXTRA_DIST = elfutils.spec GPG-KEY NOTES CONTRIBUTING \
|
|
COPYING COPYING-GPLV2 COPYING-LGPLV3
|
|
diff --git a/configure.ac b/configure.ac
|
|
index c2c1d90b2133..7b4c38381cca 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -259,6 +259,12 @@ AC_SUBST([LIBEBL_SUBDIR])
|
|
AC_DEFINE_UNQUOTED(LIBEBL_SUBDIR, "$LIBEBL_SUBDIR")
|
|
AH_TEMPLATE([LIBEBL_SUBDIR], [$libdir subdirectory containing libebl modules.])
|
|
|
|
+AC_ARG_ENABLE([progs],
|
|
+ AS_HELP_STRING([--enable-progs], [enable progs]),
|
|
+ enable_progs=$enableval,
|
|
+ enable_progs=yes)
|
|
+AM_CONDITIONAL(ENABLE_PROGS, test "$enable_progs" = yes)
|
|
+
|
|
dnl zlib is mandatory.
|
|
save_LIBS="$LIBS"
|
|
LIBS=
|
|
--
|
|
2.11.0
|
|
|