cddec3093e
The list of changes is too long to repeat here, but lots of fixes and improvements, plus a brand new rewrite of the DVB handling code. Refresh patches, except patch 4 which has now been upstreamed. Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
66 lines
2.7 KiB
Diff
66 lines
2.7 KiB
Diff
Do not download transponder data as part of the build
|
|
|
|
If dvb-scan is enabled, tvheadend will download the transponders data
|
|
from the dvb-apps package. This does not play well with buildroot.
|
|
|
|
Instead, we rely on the dvb-apps package to install those files, so
|
|
it is no longer needed to install those as part of tvheadend.
|
|
|
|
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
|
|
|
|
diff -durN tvheadend-c84bc2b72b462ef2dbed305f3fd0bb3fa5046fc3.orig/configure tvheadend-c84bc2b72b462ef2dbed305f3fd0bb3fa5046fc3/configure
|
|
--- tvheadend-c84bc2b72b462ef2dbed305f3fd0bb3fa5046fc3.orig/configure 2014-03-07 21:44:39.000000000 +0100
|
|
+++ tvheadend-c84bc2b72b462ef2dbed305f3fd0bb3fa5046fc3/configure 2014-03-09 14:44:09.350095543 +0100
|
|
@@ -272,15 +272,16 @@
|
|
#
|
|
# DVB scan
|
|
#
|
|
-if enabled linuxdvb && enabled dvbscan; then
|
|
- printf "${TAB}" "fetching dvb-scan files ..."
|
|
- "${ROOTDIR}/support/getmuxlist"
|
|
- if [ $? -ne 0 ]; then
|
|
- echo "fail"
|
|
- die "Failed to fetch dvb-scan data (use --disable-dvbscan)"
|
|
- fi
|
|
- echo "ok"
|
|
-fi
|
|
+# For buildroot, we already installed those files via the dvb-apps package
|
|
+#if enabled linuxdvb && enabled dvbscan; then
|
|
+# printf "${TAB}" "fetching dvb-scan files ..."
|
|
+# "${ROOTDIR}/support/getmuxlist"
|
|
+# if [ $? -ne 0 ]; then
|
|
+# echo "fail"
|
|
+# die "Failed to fetch dvb-scan data (use --disable-dvbscan)"
|
|
+# fi
|
|
+# echo "ok"
|
|
+#fi
|
|
|
|
#
|
|
# epoll
|
|
diff -durN tvheadend-c84bc2b72b462ef2dbed305f3fd0bb3fa5046fc3.orig/Makefile tvheadend-c84bc2b72b462ef2dbed305f3fd0bb3fa5046fc3/Makefile
|
|
--- tvheadend-c84bc2b72b462ef2dbed305f3fd0bb3fa5046fc3.orig/Makefile 2014-03-07 21:44:39.000000000 +0100
|
|
+++ tvheadend-c84bc2b72b462ef2dbed305f3fd0bb3fa5046fc3/Makefile 2014-03-09 14:44:09.350095543 +0100
|
|
@@ -255,7 +255,7 @@
|
|
SRCS-${CONFIG_BUNDLE} += bundle.c
|
|
BUNDLES-yes += docs/html docs/docresources src/webui/static
|
|
BUNDLES-yes += data/conf
|
|
-BUNDLES-${CONFIG_DVBSCAN} += data/dvb-scan
|
|
+#BUNDLES-${CONFIG_DVBSCAN} += data/dvb-scan
|
|
BUNDLES = $(BUNDLES-yes)
|
|
|
|
#
|
|
diff -durN tvheadend-c84bc2b72b462ef2dbed305f3fd0bb3fa5046fc3.orig/support/posix.mk tvheadend-c84bc2b72b462ef2dbed305f3fd0bb3fa5046fc3/support/posix.mk
|
|
--- tvheadend-c84bc2b72b462ef2dbed305f3fd0bb3fa5046fc3.orig/support/posix.mk 2014-03-07 21:44:39.000000000 +0100
|
|
+++ tvheadend-c84bc2b72b462ef2dbed305f3fd0bb3fa5046fc3/support/posix.mk 2014-03-09 14:44:09.350095543 +0100
|
|
@@ -17,6 +17,10 @@
|
|
|
|
find ${DESTDIR}${datadir}/tvheadend -name .git -exec rm -rf {} \; &>/dev/null || /bin/true
|
|
|
|
+ mkdir -p ${DESTDIR}${datadir}/tvheadend/data
|
|
+ rm -f ${DESTDIR}${datadir}/tvheadend/data/dvb-scan
|
|
+ ln -sf /usr/share/dvb ${DESTDIR}${datadir}/tvheadend/data/dvb-scan
|
|
+
|
|
uninstall:
|
|
rm -f ${DESTDIR}${bindir}/tvheadend
|
|
rm -f ${DESTDIR}${mandir}/man1/tvheadend.1
|