c2a39ba528
https://sourceware.org/ml/gdb-announce/2018/msg00001.html gdb 8.1 has a new optional dependency on mpfr, which according to the NEWS file: GDB now uses the GNU MPFR library, if available, to emulate target floating-point arithmetic during expression evaluation when the target uses different floating-point formats than the host. At least version 3.1 of GNU MPFR is required. So for the target gdb, this is unnecessary, and therefore we forcefully disable mpfr support by passing --without-mpfr. For the host gdb, it would potentially be useful, but since it's a new feature that isn't essential, we for now keep it disabled as well. An option may be added later if needed. To avoid gnulib issues with uClibc/musl, we need to pass additional configure/make variables, like is done in OpenEmbedded [1]. [1] http://git.openembedded.org/openembedded-core/tree/meta/recipes-devtools/gdb/gdb_8.1.bb?id=02664a8dcd1ebb6cd77248e1b97a78390ea06033#n9 We re-add the same patches as the ones present for gdb 8.0.1, except 0004-nat-linux-ptrace.c-add-missing-gdb_byte-cast.patch, which was merged upstream. Signed-off-by: Romain Naour <romain.naour@gmail.com> [Thomas: change mpfr handling.] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
56 lines
1.4 KiB
Diff
56 lines
1.4 KiB
Diff
From 2acd9d3eb703b9a64ac92b3880ed546bec92af95 Mon Sep 17 00:00:00 2001
|
|
From: Khem Raj <raj.khem@gmail.com>
|
|
Date: Sat, 6 Aug 2016 17:32:50 -0700
|
|
Subject: [PATCH] ppc/ptrace: Define pt_regs uapi_pt_regs on !GLIBC systems
|
|
|
|
Upstream-Status: Pending
|
|
|
|
Signed-off-by: Khem Raj <raj.khem@gmail.com>
|
|
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
[Rebase on gdb 8.0]
|
|
Signed-off-by: Romain Naour <romain.naour@gmail.com>
|
|
---
|
|
gdb/gdbserver/linux-ppc-low.c | 6 ++++++
|
|
gdb/nat/ppc-linux.h | 6 ++++++
|
|
2 files changed, 12 insertions(+)
|
|
|
|
diff --git a/gdb/gdbserver/linux-ppc-low.c b/gdb/gdbserver/linux-ppc-low.c
|
|
index 33a9feb..1a9141f 100644
|
|
--- a/gdb/gdbserver/linux-ppc-low.c
|
|
+++ b/gdb/gdbserver/linux-ppc-low.c
|
|
@@ -21,7 +21,13 @@
|
|
#include "linux-low.h"
|
|
|
|
#include <elf.h>
|
|
+#if !defined(__GLIBC__)
|
|
+# define pt_regs uapi_pt_regs
|
|
+#endif
|
|
#include <asm/ptrace.h>
|
|
+#if !defined(__GLIBC__)
|
|
+# undef pt_regs
|
|
+#endif
|
|
|
|
#include "nat/ppc-linux.h"
|
|
#include "linux-ppc-tdesc.h"
|
|
diff --git a/gdb/nat/ppc-linux.h b/gdb/nat/ppc-linux.h
|
|
index 5837ea1..7233929 100644
|
|
--- a/gdb/nat/ppc-linux.h
|
|
+++ b/gdb/nat/ppc-linux.h
|
|
@@ -18,7 +18,13 @@
|
|
#ifndef PPC_LINUX_H
|
|
#define PPC_LINUX_H 1
|
|
|
|
+#if !defined(__GLIBC__)
|
|
+# define pt_regs uapi_pt_regs
|
|
+#endif
|
|
#include <asm/ptrace.h>
|
|
+#if !defined(__GLIBC__)
|
|
+# undef pt_regs
|
|
+#endif
|
|
#include <asm/cputable.h>
|
|
|
|
/* This sometimes isn't defined. */
|
|
--
|
|
2.9.4
|
|
|