2620a1ac2d
This version of libftdi can coexists beside the 0.x version. Signed-off-by: Daniel Sangue <daniel.sangue@sangue.ch> [Samuel Martin: - libftdi1.mk: bump to version 1.2 and add hash - cleanup uneeded libusb-compat stuff - Config.in: add comment when ftdipp1 deps are not met - fix typos in variable names and legit CMake options for *_CONF_OPTS - add support for python bindings and ftdi_eeprom - fix static build - fix build with toolchain w/o C++ support ] Signed-off-by: Samuel Martin <s.martin49@gmail.com> [Thomas: - reorder Config.in option properties: first the "bool" property, then the "selects", then the "depends on". - remove "thread" dependency from the libftdipp1 comment since the whole package can anyway not be selected if there's no thread support. - fix a big mistake in the .mk file: $(if BR2_PACKAGE_PYTHON,python,python3) replaced by: $(if $(BR2_PACKAGE_PYTHON),python,python3) - add license information.] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
35 lines
1.2 KiB
Diff
35 lines
1.2 KiB
Diff
From 81275d75ae88fe8ab1915d3ba260ea935e63c362 Mon Sep 17 00:00:00 2001
|
|
From: Samuel Martin <s.martin49@gmail.com>
|
|
Date: Sun, 25 Jan 2015 10:01:17 +0100
|
|
Subject: [PATCH 2/2] cmake: fix FindUSB1.cmake
|
|
|
|
Make sure all ldflags are correctly set, especially for static build.
|
|
|
|
Signed-off-by: Samuel Martin <s.martin49@gmail.com>
|
|
---
|
|
cmake/FindUSB1.cmake | 8 ++++++--
|
|
1 file changed, 6 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/cmake/FindUSB1.cmake b/cmake/FindUSB1.cmake
|
|
index b90e297..e7f1b3c 100644
|
|
--- a/cmake/FindUSB1.cmake
|
|
+++ b/cmake/FindUSB1.cmake
|
|
@@ -26,8 +26,12 @@ else (LIBUSB_INCLUDE_DIR AND LIBUSB_LIBRARIES)
|
|
PATH_SUFFIXES libusb-1.0
|
|
PATHS ${PC_LIBUSB_INCLUDEDIR} ${PC_LIBUSB_INCLUDE_DIRS})
|
|
|
|
- FIND_LIBRARY(LIBUSB_LIBRARIES NAMES usb-1.0
|
|
- PATHS ${PC_LIBUSB_LIBDIR} ${PC_LIBUSB_LIBRARY_DIRS})
|
|
+ set(LIBUSB_LIBRARIES ${PC_LIBUSB_STATIC_LDFLAGS} ${PC_LIBUSB_STATIC_LDFLAGS_OTHER})
|
|
+ foreach(libname ${PC_LIBUSB_STATIC_LIBRARIES})
|
|
+ FIND_LIBRARY(lib NAMES ${libname}
|
|
+ PATHS ${PC_LIBUSB_LIBDIR} ${PC_LIBUSB_LIBRARY_DIRS})
|
|
+ list(APPEND LIBUSB_LIBRARIES ${lib})
|
|
+ endforeach()
|
|
|
|
include(FindPackageHandleStandardArgs)
|
|
FIND_PACKAGE_HANDLE_STANDARD_ARGS(LIBUSB DEFAULT_MSG LIBUSB_LIBRARIES LIBUSB_INCLUDE_DIR)
|
|
--
|
|
2.2.2
|
|
|