2620a1ac2d
This version of libftdi can coexists beside the 0.x version. Signed-off-by: Daniel Sangue <daniel.sangue@sangue.ch> [Samuel Martin: - libftdi1.mk: bump to version 1.2 and add hash - cleanup uneeded libusb-compat stuff - Config.in: add comment when ftdipp1 deps are not met - fix typos in variable names and legit CMake options for *_CONF_OPTS - add support for python bindings and ftdi_eeprom - fix static build - fix build with toolchain w/o C++ support ] Signed-off-by: Samuel Martin <s.martin49@gmail.com> [Thomas: - reorder Config.in option properties: first the "bool" property, then the "selects", then the "depends on". - remove "thread" dependency from the libftdipp1 comment since the whole package can anyway not be selected if there's no thread support. - fix a big mistake in the .mk file: $(if BR2_PACKAGE_PYTHON,python,python3) replaced by: $(if $(BR2_PACKAGE_PYTHON),python,python3) - add license information.] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
47 lines
1.2 KiB
Diff
47 lines
1.2 KiB
Diff
From c215d5ecd985b57700e817920d0e99112b4a571b Mon Sep 17 00:00:00 2001
|
|
From: Samuel Martin <s.martin49@gmail.com>
|
|
Date: Sun, 25 Jan 2015 13:35:24 +0100
|
|
Subject: [PATCH] cmake: do not check for g++ when FTDIPP is disabled
|
|
|
|
Signed-off-by: Samuel Martin <s.martin49@gmail.com>
|
|
---
|
|
CMakeLists.txt | 6 ++++--
|
|
ftdipp/CMakeLists.txt | 1 +
|
|
2 files changed, 5 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|
index 0ba0b08..e880211 100644
|
|
--- a/CMakeLists.txt
|
|
+++ b/CMakeLists.txt
|
|
@@ -1,5 +1,5 @@
|
|
# Project
|
|
-project(libftdi1)
|
|
+project(libftdi1 C)
|
|
set(MAJOR_VERSION 1)
|
|
set(MINOR_VERSION 2)
|
|
set(PACKAGE libftdi1)
|
|
@@ -145,7 +145,9 @@ else(DOCUMENTATION AND DOXYGEN_FOUND)
|
|
endif(DOCUMENTATION AND DOXYGEN_FOUND)
|
|
|
|
add_subdirectory(src)
|
|
-add_subdirectory(ftdipp)
|
|
+if(FTDIPP)
|
|
+ add_subdirectory(ftdipp)
|
|
+endif()
|
|
add_subdirectory(python)
|
|
add_subdirectory(ftdi_eeprom)
|
|
add_subdirectory(examples)
|
|
diff --git a/ftdipp/CMakeLists.txt b/ftdipp/CMakeLists.txt
|
|
index 27e7884..2d080f4 100644
|
|
--- a/ftdipp/CMakeLists.txt
|
|
+++ b/ftdipp/CMakeLists.txt
|
|
@@ -1,4 +1,5 @@
|
|
# Check
|
|
+project(libftdipp1 C CXX)
|
|
set(FTDI_BUILD_CPP False PARENT_SCOPE)
|
|
|
|
option ( FTDIPP "Build C++ binding library libftdi1++" ON )
|
|
--
|
|
2.2.2
|
|
|