160f83db02
And update 0001-configure-add-disable-runtime-tests-option.patch. For details see [1]. [1] https://lists.freedesktop.org/archives/input-tools/2016-November/001375.html Signed-off-by: Peter Seiderer <ps.report@gmx.net> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
52 lines
1.9 KiB
Diff
52 lines
1.9 KiB
Diff
From fe965061b4306e3ca811ff86dc1ca29f7db9af18 Mon Sep 17 00:00:00 2001
|
|
From: Peter Seiderer <ps.report@gmx.net>
|
|
Date: Sun, 11 Oct 2015 13:33:19 +0200
|
|
Subject: [PATCH] configure: add '--disable-runtime-tests' option
|
|
|
|
Signed-off-by: Peter Seiderer <ps.report@gmx.net>
|
|
---
|
|
configure.ac | 15 +++++++++++----
|
|
1 file changed, 11 insertions(+), 4 deletions(-)
|
|
|
|
diff --git a/configure.ac b/configure.ac
|
|
index c1a9111..8fe7b8b 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -76,13 +76,20 @@ else
|
|
AC_MSG_WARN([check not found - skipping building unit tests])
|
|
fi
|
|
AM_CONDITIONAL(HAVE_VALGRIND, [test "x$VALGRIND" != "x"])
|
|
-AM_CONDITIONAL(ENABLE_RUNTIME_TESTS, [test "x$HAVE_CHECK" = "xyes"])
|
|
+
|
|
+AC_ARG_ENABLE([runtime-tests],
|
|
+ AS_HELP_STRING([--disable-runtime-tests], [Disable runtime tests]))
|
|
+AS_IF([test "x$enable_runtime_tests" != "xno"],
|
|
+ [enable_runtime_tests=yes],
|
|
+ [enable_runtime_tests=no])
|
|
+
|
|
+AM_CONDITIONAL(ENABLE_RUNTIME_TESTS, [test "x${enable_runtime_tests}x$HAVE_CHECK" = "xyesxyes"])
|
|
AM_CONDITIONAL(ENABLE_STATIC_LINK_TEST, [test "x$enable_static" = "xyes"])
|
|
|
|
AC_ARG_ENABLE([test-run],
|
|
AS_HELP_STRING([--enable-test-run], [For internal use only]),
|
|
[run_tests="$enableval"], [run_tests="yes"])
|
|
-AM_CONDITIONAL(RUN_TESTS, [test "x$run_tests" = "xyes"])
|
|
+AM_CONDITIONAL(RUN_TESTS, [test "x${enable_runtime_tests}x$run_tests" = "xyesxyes"])
|
|
|
|
with_cflags=""
|
|
if test "x$GCC" = "xyes"; then
|
|
@@ -167,8 +174,8 @@ AC_MSG_RESULT([
|
|
Libdir ${libdir}
|
|
|
|
Build documentation ${have_doxygen}
|
|
- Enable unit-tests ${HAVE_CHECK}
|
|
- Run unit-tests ${run_tests}
|
|
+ Enable unit-tests ${HAVE_CHECK} (runtime-tests: ${enable_runtime_tests})
|
|
+ Run unit-tests ${run_tests} (runtime-tests: ${enable_runtime_tests})
|
|
Enable profiling ${enable_gcov}
|
|
Static library symbol check ${static_symbol_leaks_test}
|
|
])
|
|
--
|
|
2.11.0
|
|
|