584312d16f
Fixes: - http://autobuild.buildroot.org/results/418a40b995e91bc66e692dfbc4b0521db3fa5fbb Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
34 lines
1.1 KiB
Diff
34 lines
1.1 KiB
Diff
From 0e8c3c4851ce64268a8ae1810ef72594251d917d Mon Sep 17 00:00:00 2001
|
|
From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
|
Date: Sun, 10 Nov 2019 21:57:12 +0100
|
|
Subject: [PATCH] Makefile: unconditionally disable PIE
|
|
|
|
Though -nostdlib is passed in $(CFLAGS), -fno-pie must also be passed to
|
|
avoid linking errors related to overlapping sections if toolchain
|
|
enforces PIE.
|
|
|
|
Fixes:
|
|
- http://autobuild.buildroot.org/results/418a40b995e91bc66e692dfbc4b0521db3fa5fbb
|
|
|
|
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
|
---
|
|
Makefile | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/Makefile b/Makefile
|
|
index 5226006..fe3d844 100644
|
|
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -17,7 +17,7 @@ CFLAGS =-march=armv7-m -mcpu=cortex-m3 -mthumb -nostdlib -Wall -Wundef \
|
|
-Werror-implicit-function-declaration -Wstrict-prototypes \
|
|
-Wdeclaration-after-statement -fno-delete-null-pointer-checks \
|
|
-Wempty-body -fno-strict-overflow -fno-stack-protector \
|
|
- -g -I$(INCLUDES) -O2
|
|
+ -fno-pie -g -I$(INCLUDES) -O2
|
|
LDFLAGS =-nostartfiles -fno-exceptions -Tfirmware.ld
|
|
|
|
EXECUTABLE=am335x-pm-firmware.elf
|
|
--
|
|
2.23.0
|
|
|