kumquat-buildroot/package/fluent-bit/0003-CMakeLists.txt-disable-cxx-support-for-librdkafka-77.patch
Thomas Devoogdt a70e226ac1 package/fluent-bit: fix build without c++
FLB_{IN,OUT}_KAFKA is enabled by default since v2.1.5,
causing compile errors if no c++ support.

These patches allow the Kafka plugin to be build without C++.

Fixes:
 - http://autobuild.buildroot.net/results/d63/d638390da721eb3bdfcc7a4229114b492aaead99/
 - http://autobuild.buildroot.net/results/709/70960056479eab860e94eed993566fcb78c4dbbe/
 - http://autobuild.buildroot.net/results/366/3667126ee954f927f83ccfbaae3c6fb8ebd07dbb/
 - http://autobuild.buildroot.net/results/9bd/9bd090216b9a8005fc3d020a9c0adf5e825bea59/
 - ...

Signed-off-by: Thomas Devoogdt <thomas@devoogdt.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
2023-07-28 21:31:52 +02:00

30 lines
906 B
Diff

From f5303533fb64bf038dbd8203ac52d94819346239 Mon Sep 17 00:00:00 2001
From: Thomas Devoogdt <thomas.devoogdt@barco.com>
Date: Tue, 25 Jul 2023 10:00:36 +0200
Subject: [PATCH] CMakeLists.txt: disable cxx support for librdkafka #7741
Fluent-bit is c only, so no need to compile cxx.
This fixes also a compile error in buildroot.
Upstream: https://github.com/fluent/fluent-bit/pull/7765/commits
Signed-off-by: Thomas Devoogdt <thomas.devoogdt@barco.com>
---
CMakeLists.txt | 1 +
1 file changed, 1 insertion(+)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index df6b283cf..10e6071f3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -967,6 +967,7 @@ if(FLB_BACKTRACE)
endif()
if(FLB_IN_KAFKA OR FLB_OUT_KAFKA)
+ FLB_OPTION(RDKAFKA_BUILD_CXX Off)
FLB_OPTION(RDKAFKA_BUILD_STATIC On)
FLB_OPTION(RDKAFKA_BUILD_EXAMPLES Off)
FLB_OPTION(RDKAFKA_BUILD_TESTS Off)
--
2.34.1