f7c8cd89c9
The current method of supporting static only build, removal of all lines that match the SHARED regex from lib/Makefile, is crude and fragile. Instead, patch lib/Makefile to allow disable of shared libraries. Signed-off-by: Baruch Siach <baruch@tkos.co.il> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
60 lines
1.9 KiB
Diff
60 lines
1.9 KiB
Diff
From 95bde2a4ae4a92e984a5783ca1f09f44bf04fadb Mon Sep 17 00:00:00 2001
|
|
From: Baruch Siach <baruch@tkos.co.il>
|
|
Date: Thu, 19 Apr 2018 12:28:11 +0300
|
|
Subject: [PATCH] lib: allow to disable shared libraries
|
|
|
|
Just like BUILD_STATIC=no disables static libraries, BUILD_SHARED=no
|
|
disabled shared libraries. This is useful to support toolchains that do
|
|
not support shared libraries.
|
|
|
|
Signed-off-by: Baruch Siach <baruch@tkos.co.il>
|
|
---
|
|
Upstream status: https://github.com/lz4/lz4/pull/504
|
|
|
|
lib/Makefile | 5 +++++
|
|
1 file changed, 5 insertions(+)
|
|
|
|
diff --git a/lib/Makefile b/lib/Makefile
|
|
index dd33f50351a8..976d57cd75ed 100644
|
|
--- a/lib/Makefile
|
|
+++ b/lib/Makefile
|
|
@@ -42,6 +42,7 @@ LIBVER_MINOR := $(shell echo $(LIBVER_MINOR_SCRIPT))
|
|
LIBVER_PATCH := $(shell echo $(LIBVER_PATCH_SCRIPT))
|
|
LIBVER := $(shell echo $(LIBVER_SCRIPT))
|
|
|
|
+BUILD_SHARED:=yes
|
|
BUILD_STATIC:=yes
|
|
|
|
CPPFLAGS+= -DXXH_NAMESPACE=LZ4_
|
|
@@ -92,6 +93,7 @@ ifeq ($(BUILD_STATIC),yes) # can be disabled on command line
|
|
endif
|
|
|
|
$(LIBLZ4): $(SRCFILES)
|
|
+ifeq ($(BUILD_SHARED),yes) # can be disabled on command line
|
|
@echo compiling dynamic library $(LIBVER)
|
|
ifneq (,$(filter Windows%,$(OS)))
|
|
@$(CC) $(FLAGS) -DLZ4_DLL_EXPORT=1 -shared $^ -o dll\$@.dll
|
|
@@ -102,6 +104,7 @@ else
|
|
@ln -sf $@ liblz4.$(SHARED_EXT_MAJOR)
|
|
@ln -sf $@ liblz4.$(SHARED_EXT)
|
|
endif
|
|
+endif
|
|
|
|
liblz4: $(LIBLZ4)
|
|
|
|
@@ -159,9 +162,11 @@ ifeq ($(BUILD_STATIC),yes)
|
|
@$(INSTALL_DATA) liblz4.a $(DESTDIR)$(LIBDIR)/liblz4.a
|
|
@$(INSTALL_DATA) lz4frame_static.h $(DESTDIR)$(INCLUDEDIR)/lz4frame_static.h
|
|
endif
|
|
+ifeq ($(BUILD_SHARED),yes)
|
|
@$(INSTALL_PROGRAM) liblz4.$(SHARED_EXT_VER) $(DESTDIR)$(LIBDIR)
|
|
@ln -sf liblz4.$(SHARED_EXT_VER) $(DESTDIR)$(LIBDIR)/liblz4.$(SHARED_EXT_MAJOR)
|
|
@ln -sf liblz4.$(SHARED_EXT_VER) $(DESTDIR)$(LIBDIR)/liblz4.$(SHARED_EXT)
|
|
+endif
|
|
@echo Installing headers in $(INCLUDEDIR)
|
|
@$(INSTALL_DATA) lz4.h $(DESTDIR)$(INCLUDEDIR)/lz4.h
|
|
@$(INSTALL_DATA) lz4hc.h $(DESTDIR)$(INCLUDEDIR)/lz4hc.h
|
|
--
|
|
2.17.0
|
|
|