7011c7fe12
Debian have removed version 5.1.2 patchlevel 6 from their FTP servers, replacing it with 5.1.2 patchlevel 6.1. The resulting patch applies cleanly, but one of the buildroot patches does not apply cleanly unless modified. Patch is included to fix this.
34 lines
1.2 KiB
Diff
34 lines
1.2 KiB
Diff
diff -urN net-snmp-5.1-dist/agent/mibgroup/host/hr_system.c net-snmp-5.1/agent/mibgroup/host/hr_system.c
|
|
--- net-snmp-5.1-dist/agent/mibgroup/host/hr_system.c 2004-02-22 17:29:34.000000000 +0000
|
|
+++ net-snmp-5.1/agent/mibgroup/host/hr_system.c 2005-05-27 15:15:52.363982808 +0100
|
|
@@ -603,7 +603,11 @@
|
|
current user */
|
|
if (kill(utmp_p->ut_pid, 0) == -1 && errno == ESRCH) {
|
|
utmp_p->ut_type = DEAD_PROCESS;
|
|
- pututline(utmp_p);
|
|
+#if HAVE_UTMPX_H
|
|
+ pututxline(utmp_p);
|
|
+#else
|
|
+ pututline(utmp_p);
|
|
+#endif
|
|
continue;
|
|
}
|
|
#endif
|
|
diff -urN net-snmp-5.1-dist/configure.in net-snmp-5.1/configure.in
|
|
--- net-snmp-5.1-dist/configure.in 2004-03-31 21:59:14.000000000 -0600
|
|
+++ net-snmp-5.1/configure.in 2004-03-31 22:06:05.000000000 -0600
|
|
@@ -1865,13 +1865,8 @@
|
|
if test $cross_compiling = yes; then
|
|
if test $with_endianness = "big"; then
|
|
AC_DEFINE(WORDS_BIGENDIAN)
|
|
- elif test -z $with_endianness; then
|
|
- AC_MSG_ERROR([You are cross-compiling, but you have not specified the target's endianness])
|
|
fi
|
|
else
|
|
- if test $with_endianness; then
|
|
- AC_MSG_ERROR([Endianness has been specified, but you are not cross-compiling.])
|
|
- fi
|
|
AC_C_BIGENDIAN
|
|
fi
|
|
|