kumquat-buildroot/package/mraa/0002-CMakeLists.txt-do-not-require-a-CXX-compiler.patch
Pieterjan Camerlynck 8f6b5d4cb3 mraa: new package
mraa provides a unified interface for IO on Galileo, Edison,
Raspberry Pi and others.

Signed-off-by: Pieterjan Camerlynck <pieterjan.camerlynck@gmail.com>
Tested-by: Samuel Martin <s.martin49@gmail.com>
Acked-by: Samuel Martin <s.martin49@gmail.com>
Reviewed-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
2016-01-12 21:59:00 +01:00

58 lines
1.7 KiB
Diff

Upstream status: Merged
Fetched from: https://github.com/intel-iot-devkit/mraa/commit/a87a104efeb83d4e762992e5be3b8908e6d2bf40
From a87a104efeb83d4e762992e5be3b8908e6d2bf40 Mon Sep 17 00:00:00 2001
From: Pieterjan Camerlynck <pieterjan.camerlynck@gmail.com>
Date: Tue, 5 Jan 2016 19:36:55 +0100
Subject: [PATCH] CMakeLists.txt: do not require a C++ compiler
By default, CMake assumes both a C and C++ compiler are required.
This is not needed for mraa because it only provides C++ header
files. Note that if using SWIG you need one and if using node.js 3+ you'll need
a C++11 compiler
Signed-off-by: Pieterjan Camerlynck <pieterjan.camerlynck@gmail.com>
Signed-off-by: Brendan Le Foll <brendan.le.foll@intel.com>
---
CMakeLists.txt | 2 +-
examples/c++/CMakeLists.txt | 2 ++
src/CMakeLists.txt | 1 +
3 files changed, 4 insertions(+), 1 deletion(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6a189b9..4457efc 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,5 +1,5 @@
cmake_minimum_required (VERSION 2.8)
-project (mraa)
+project (mraa C)
FIND_PACKAGE (Threads REQUIRED)
diff --git a/examples/c++/CMakeLists.txt b/examples/c++/CMakeLists.txt
index 69714aa..d688d48 100644
--- a/examples/c++/CMakeLists.txt
+++ b/examples/c++/CMakeLists.txt
@@ -1,3 +1,5 @@
+enable_language(CXX)
+
add_executable (AioA0 AioA0.cpp)
add_executable (blink-io-cpp Blink-IO.cpp)
add_executable (Pwm3-cycle Pwm3-cycle.cpp)
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 6698fa4..05b546c 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -171,6 +171,7 @@ if (DOXYGEN_FOUND)
endif ()
if (BUILDSWIG)
+ enable_language(CXX)
find_package (SWIG)
if (SWIG_FOUND)
include (${SWIG_USE_FILE})
--
1.9.1