cb75d8167f
Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
68 lines
2.3 KiB
Diff
68 lines
2.3 KiB
Diff
From 9382ae2431d2962c430e7149302c8690f5bc159c Mon Sep 17 00:00:00 2001
|
|
From: "Yann E. MORIN" <yann.morin.1998@free.fr>
|
|
Date: Sun, 10 Jul 2016 15:06:15 +0200
|
|
Subject: [PATCH] build: do not use -Werror
|
|
|
|
Warnings come and go with various compiler versions, so using -Werror is
|
|
prone to cause build failures with various compiler versions, especially
|
|
newer versions that introduce new warnings.
|
|
|
|
Remove use of -Werror.
|
|
|
|
[Vincent: tweak patch for 20170531 release]
|
|
|
|
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
|
|
Signed-off-by: "Vicente Olivert Riera" <Vincent.Riera@imgtec.com>
|
|
---
|
|
generate/unix/Makefile.config | 1 -
|
|
generate/unix/iasl/Makefile | 12 ++++++------
|
|
2 files changed, 6 insertions(+), 7 deletions(-)
|
|
|
|
diff --git a/generate/unix/Makefile.config b/generate/unix/Makefile.config
|
|
index 4d4f182..a7120e3 100644
|
|
--- a/generate/unix/Makefile.config
|
|
+++ b/generate/unix/Makefile.config
|
|
@@ -194,7 +194,6 @@ CWARNINGFLAGS = \
|
|
-Wall\
|
|
-Wbad-function-cast\
|
|
-Wdeclaration-after-statement\
|
|
- -Werror\
|
|
-Wformat=2\
|
|
-Wmissing-declarations\
|
|
-Wmissing-prototypes\
|
|
diff --git a/generate/unix/iasl/Makefile b/generate/unix/iasl/Makefile
|
|
index 156c23a..28ffc06 100644
|
|
--- a/generate/unix/iasl/Makefile
|
|
+++ b/generate/unix/iasl/Makefile
|
|
@@ -335,24 +335,24 @@ $(OBJDIR)/prparserparse.c $(OBJDIR)/prparser.y.h : $(ASL_COMPILER)/prparse
|
|
#
|
|
$(OBJDIR)/aslcompilerlex.o : $(OBJDIR)/aslcompilerlex.c
|
|
@echo "- " "Intermediate" $<
|
|
- @$(CC) -c $(CFLAGS) -Wall -Werror -o$@ $<
|
|
+ @$(CC) -c $(CFLAGS) -Wall -o$@ $<
|
|
|
|
$(OBJDIR)/aslcompilerparse.o : $(OBJDIR)/aslcompilerparse.c
|
|
@echo "- " "Intermediate" $<
|
|
- @$(CC) -c $(CFLAGS) -Wall -Werror -o$@ $<
|
|
+ @$(CC) -c $(CFLAGS) -Wall -o$@ $<
|
|
|
|
$(OBJDIR)/dtparserlex.o : $(OBJDIR)/dtparserlex.c
|
|
@echo "- " "Intermediate" $<
|
|
- @$(CC) -c $(CFLAGS) -Wall -Werror -o$@ $<
|
|
+ @$(CC) -c $(CFLAGS) -Wall -o$@ $<
|
|
|
|
$(OBJDIR)/dtparserparse.o : $(OBJDIR)/dtparserparse.c
|
|
@echo "- " "Intermediate" $<
|
|
- @$(CC) -c $(CFLAGS) -Wall -Werror -o$@ $<
|
|
+ @$(CC) -c $(CFLAGS) -Wall -o$@ $<
|
|
|
|
$(OBJDIR)/prparserlex.o : $(OBJDIR)/prparserlex.c
|
|
@echo "- " "Intermediate" $<
|
|
- @$(CC) -c $(CFLAGS) -Wall -Werror -o$@ $<
|
|
+ @$(CC) -c $(CFLAGS) -Wall -o$@ $<
|
|
|
|
$(OBJDIR)/prparserparse.o : $(OBJDIR)/prparserparse.c
|
|
@echo "- " "Intermediate" $<
|
|
- @$(CC) -c $(CFLAGS) -Wall -Werror -o$@ $<
|
|
+ @$(CC) -c $(CFLAGS) -Wall -o$@ $<
|