871846cad4
Add and use a --{enable,disable}-progs configuration option to selectively enable or disable the elfutils programs. Generally, on an embedded system, the libraries are more useful than the programs, and being able to not build the programs will make it easier to build the elfutils libraries on uClibc. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
48 lines
1.6 KiB
Diff
48 lines
1.6 KiB
Diff
Add a --{enable,disable}-progs configure option
|
|
|
|
Add a --{enable,disable}-progs configuration option to elfutils. This
|
|
allows to selectively disable the compilation of the elfutils programs
|
|
(in which case only the libraries are built and installed). This is
|
|
useful because the programs are often not needed, and also because
|
|
building the programs against uClibc causes several issues (lack of
|
|
obstack_printf() in uClibc for example).
|
|
|
|
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
|
|
Index: b/Makefile.am
|
|
===================================================================
|
|
--- a/Makefile.am
|
|
+++ b/Makefile.am
|
|
@@ -22,9 +22,13 @@
|
|
|
|
pkginclude_HEADERS = version.h
|
|
|
|
+if ENABLE_PROGS
|
|
+PROGS_SUBDIR = src
|
|
+endif
|
|
+
|
|
# Add doc back when we have some real content.
|
|
SUBDIRS = config m4 lib libelf libebl libdwfl libdw libcpu libasm backends \
|
|
- src po tests
|
|
+ $(PROGS_SUBDIR) po tests
|
|
|
|
EXTRA_DIST = elfutils.spec GPG-KEY NOTES CONTRIBUTING \
|
|
COPYING COPYING-GPLV2 COPYING-LGPLV3
|
|
Index: b/configure.ac
|
|
===================================================================
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -263,6 +263,12 @@
|
|
AC_DEFINE_UNQUOTED(LIBEBL_SUBDIR, "$LIBEBL_SUBDIR")
|
|
AH_TEMPLATE([LIBEBL_SUBDIR], [$libdir subdirectory containing libebl modules.])
|
|
|
|
+AC_ARG_ENABLE([progs],
|
|
+ AS_HELP_STRING([--enable-progs], [enable progs]),
|
|
+ enable_progs=$enableval,
|
|
+ enable_progs=yes)
|
|
+AM_CONDITIONAL(ENABLE_PROGS, test "$enable_progs" = yes)
|
|
+
|
|
dnl Test for zlib and bzlib, gives ZLIB/BZLIB .am
|
|
dnl conditional and config.h USE_ZLIB/USE_BZLIB #define.
|
|
save_LIBS="$LIBS"
|