aeaf66fc7a
- Adapt current patch for 2.2.0. - Adapt gtk configure options for 2.2.0: - Instead of --enable-gtk3 or --enable-gtk2, now it uses --enable-gtk=[no/2/3/yes]. - Remove non-existing configure options: - --enable-usr-local: removed by https://code.wireshark.org/review/gitweb?p=wireshark.git;a=commit;h=125989780ba8e658ad0d1f1c71ec01e6d36a2266 Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
36 lines
1.1 KiB
Diff
36 lines
1.1 KiB
Diff
From 25d313275e87dc236e86c0e713cad08ea64253f8 Mon Sep 17 00:00:00 2001
|
|
From: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
|
|
Date: Thu, 8 Sep 2016 10:58:34 +0100
|
|
Subject: [PATCH] configure.ac: do not assume broken inet_pton in case of cross
|
|
compiling
|
|
|
|
Patch configure.ac to not assume broken inet_pton in case of cross
|
|
compiling.
|
|
|
|
[Vincent: adapt the patch for 2.2.0]
|
|
|
|
Signed-off-by: Peter Seiderer <ps.report@gmx.net>
|
|
Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
|
|
---
|
|
configure.ac | 4 ++--
|
|
1 file changed, 2 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/configure.ac b/configure.ac
|
|
index c43e366..9672831 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -2373,8 +2373,8 @@ int main()
|
|
#endif
|
|
}], [AC_MSG_RESULT(ok);
|
|
have_inet_pton=yes], [AC_MSG_RESULT(broken);
|
|
-have_inet_pton=no], [AC_MSG_RESULT([cross compiling, assume it is broken]);
|
|
-have_inet_pton=no])],
|
|
+have_inet_pton=no], [AC_MSG_RESULT([cross compiling, assume it is broken... not here]);
|
|
+have_inet_pton=yes])],
|
|
have_inet_pton=no)
|
|
if test "$have_inet_pton" = no; then
|
|
AC_LIBOBJ(inet_pton)
|
|
--
|
|
2.7.3
|
|
|