ab4538c909
Add option to enable wipefs as a standalone app, so that it may be enabled when the flag --disable-all-packages is set. Signed-off-by: Sam Voss <sam.voss@gmail.com> Tested-by: Carlos Santos <unixmania@gmail.com> Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
34 lines
1.1 KiB
Diff
34 lines
1.1 KiB
Diff
From a76cd5f6abace269b60ef6f1b95526a2d09fd331 Mon Sep 17 00:00:00 2001
|
|
From: Sam Voss <sam.voss@gmail.com>
|
|
Date: Mon, 14 Oct 2019 21:19:16 -0500
|
|
Subject: [PATCH] wipefs: Allow explicitly enable/disablement
|
|
|
|
Currently if `--disable-all-packages` is set, there is no configure
|
|
option for re-enabling `wipefs`.
|
|
|
|
As the current default for `wipefs` is "enabled", add `--disable-` flag
|
|
to maintain backward compatibility.
|
|
|
|
Signed-off-by: Sam Voss <sam.voss@gmail.com>
|
|
---
|
|
configure.ac | 6 +++++-
|
|
1 file changed, 5 insertions(+), 1 deletion(-)
|
|
|
|
diff --git a/configure.ac b/configure.ac
|
|
index fc8a9507f..f70f8d1ee 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -1286,7 +1286,11 @@ UL_BUILD_INIT([findfs], [check])
|
|
UL_REQUIRES_BUILD([findfs], [libblkid])
|
|
AM_CONDITIONAL([BUILD_FINDFS], [test "x$build_findfs" = xyes])
|
|
|
|
-UL_BUILD_INIT([wipefs], [check])
|
|
+AC_ARG_ENABLE([wipefs],
|
|
+ AS_HELP_STRING([--disable-wipefs], [do not build wipefs]),
|
|
+ [], [UL_DEFAULT_ENABLE([wipefs], [check])]
|
|
+)
|
|
+UL_BUILD_INIT([wipefs])
|
|
UL_REQUIRES_BUILD([wipefs], [libblkid])
|
|
UL_REQUIRES_BUILD([wipefs], [libsmartcols])
|
|
AM_CONDITIONAL([BUILD_WIPEFS], [test "x$build_wipefs" = xyes])
|