d77014a5a3
Rebased patches on 3.8.0 Signed-off-by: James Hilliard <james.hilliard1@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
74 lines
2.2 KiB
Diff
74 lines
2.2 KiB
Diff
From c54cb57b3bd80fa2819f6409d5d2b98d82fbfcb2 Mon Sep 17 00:00:00 2001
|
|
From: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
Date: Wed, 22 Feb 2017 17:23:42 -0800
|
|
Subject: [PATCH] Add an option to disable the tk module
|
|
|
|
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
Signed-off-by: Samuel Martin <s.martin49@gmail.com>
|
|
[ Andrey Smirnov: ported to Python 3.6 ]
|
|
Signed-off-by: Andrey Smirnov <andrew.smirnov@gmail.com>
|
|
---
|
|
Makefile.pre.in | 11 ++++++++---
|
|
configure.ac | 9 +++++++++
|
|
2 files changed, 17 insertions(+), 3 deletions(-)
|
|
|
|
diff --git a/Makefile.pre.in b/Makefile.pre.in
|
|
index cf9add0bc7..5d78419fd4 100644
|
|
--- a/Makefile.pre.in
|
|
+++ b/Makefile.pre.in
|
|
@@ -1322,7 +1322,7 @@ maninstall: altmaninstall
|
|
# Install the library
|
|
XMLLIBSUBDIRS= xml xml/dom xml/etree xml/parsers xml/sax
|
|
|
|
-LIBSUBDIRS= tkinter site-packages \
|
|
+LIBSUBDIRS= site-packages \
|
|
asyncio \
|
|
collections concurrent concurrent/futures encodings \
|
|
email email/mime \
|
|
@@ -1339,8 +1339,7 @@ LIBSUBDIRS= tkinter site-packages \
|
|
venv venv/scripts venv/scripts/common venv/scripts/posix \
|
|
curses
|
|
|
|
-TESTSUBDIRS= tkinter/test tkinter/test/test_tkinter \
|
|
- tkinter/test/test_ttk test \
|
|
+TESTSUBDIRS= test \
|
|
test/audiodata \
|
|
test/capath test/data \
|
|
test/cjkencodings test/decimaltestdata \
|
|
@@ -1408,6 +1407,12 @@ TESTSUBDIRS= tkinter/test tkinter/test/test_tkinter \
|
|
test/test_tools test/test_warnings test/test_warnings/data \
|
|
unittest/test unittest/test/testmock
|
|
|
|
+ifeq (@TK@,yes)
|
|
+LIBSUBDIRS += tkinter
|
|
+TESTSUBDIRS += tkinter/test tkinter/test/test_tkinter \
|
|
+ tkinter/test/test_ttk
|
|
+endif
|
|
+
|
|
ifeq (@LIB2TO3@,yes)
|
|
LIBSUBDIRS += lib2to3 lib2to3/fixes lib2to3/pgen2
|
|
TESTSUBDIRS += lib2to3/tests \
|
|
diff --git a/configure.ac b/configure.ac
|
|
index 79a8255f44..b5922451cc 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -3222,6 +3222,15 @@ if test "$SQLITE3" = "no" ; then
|
|
DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} _sqlite3"
|
|
fi
|
|
|
|
+AC_SUBST(TK)
|
|
+AC_ARG_ENABLE(tk,
|
|
+ AS_HELP_STRING([--disable-tk], [disable tk]),
|
|
+ [ TK="${enableval}" ], [ TK=yes ])
|
|
+
|
|
+if test "$TK" = "no"; then
|
|
+ DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} _tkinter"
|
|
+fi
|
|
+
|
|
AC_SUBST(PYDOC)
|
|
|
|
AC_ARG_ENABLE(pydoc,
|
|
--
|
|
2.20.1
|
|
|