f0483751df
Update patches for meson: 0002-configure.ac-invert-order-for-wayland-scanner-check.patch 0003-set-LIBCLC_INCLUDEDIR.patch Disable unused options that are set to "auto" mode. (valgrind, gallium-omx, power8). Remove --disable-static option since there is no meson equivalent. Remove --disable-mangling since it's not yet supported by meson. Use r100 instead of radeon as DRI name for BR2_PACKAGE_MESA3D_DRI_DRIVER_RADEON. Add a new depedency on host-python3-mako since we can't use generated headers from the release archive [2]. [1] http://patchwork.ozlabs.org/patch/1084248/ [2] http://lists.busybox.net/pipermail/buildroot/2019-April/249057.html Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Romain Naour <romain.naour@smile.fr> Cc: Peter Seiderer <ps.report@gmx.net> Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
40 lines
1.6 KiB
Diff
40 lines
1.6 KiB
Diff
From 7b46756a99aca7f27a45c3b99460f088570f6f53 Mon Sep 17 00:00:00 2001
|
|
From: Romain Naour <romain.naour@smile.fr>
|
|
Date: Wed, 17 Apr 2019 23:07:42 +0200
|
|
Subject: [PATCH] meson: Set proper value for LIBCLC_INCLUDEDIR
|
|
|
|
LIBCLC_INCLUDEDIR is the location where mesa3d OpenCL implementation
|
|
will look for OpenCL "headers" on the target, when building the OpenCL
|
|
kernels.
|
|
|
|
The value returned by pkg-config for includedir is relevant when
|
|
cross-compiling, on the build machine. But in this specific case, we
|
|
really need a value that is valid on the target.
|
|
|
|
Those headers are installed by the libclc package in /usr/share so
|
|
that they are not removed by Buildroot target-finalize logic.
|
|
|
|
Based on the patch for autotools provided by Valentin Korenblit.
|
|
|
|
Signed-off-by: Romain Naour <romain.naour@smile.fr>
|
|
---
|
|
src/gallium/state_trackers/clover/meson.build | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/src/gallium/state_trackers/clover/meson.build b/src/gallium/state_trackers/clover/meson.build
|
|
index 62ac5f5278d..ecdeb39669c 100644
|
|
--- a/src/gallium/state_trackers/clover/meson.build
|
|
+++ b/src/gallium/state_trackers/clover/meson.build
|
|
@@ -49,7 +49,7 @@ libclllvm = static_library(
|
|
include_directories : clover_incs,
|
|
cpp_args : [
|
|
cpp_vis_args,
|
|
- '-DLIBCLC_INCLUDEDIR="@0@/"'.format(dep_clc.get_pkgconfig_variable('includedir')),
|
|
+ '-DLIBCLC_INCLUDEDIR="/usr/share"',
|
|
'-DLIBCLC_LIBEXECDIR="@0@/"'.format(dep_clc.get_pkgconfig_variable('libexecdir')),
|
|
'-DCLANG_RESOURCE_DIR="@0@"'.format(join_paths(
|
|
dep_llvm.get_configtool_variable('libdir'), 'clang',
|
|
--
|
|
2.20.1
|
|
|