dae0d7b3ca
Drop 0001-Complete-support-for-MIPS-n32-ABI.patch as it is now upstream and rebase 0002-Makefile.arm-remove-march-flags.patch. Also add a hash for the license file. Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
56 lines
1.7 KiB
Diff
56 lines
1.7 KiB
Diff
From e6c498f68b61057fb5505e41c3858c2b5d223227 Mon Sep 17 00:00:00 2001
|
|
From: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
Date: Sun, 7 Aug 2016 23:20:00 +0200
|
|
Subject: [PATCH] Makefile.arm: remove -march flags
|
|
|
|
The provided -march flags, especially for ARMv5 and ARMv6 may not
|
|
necessarily match the needed ones: for ARMv5, it might be armv5,
|
|
armv5te, armv5t, etc. If the wrong one is used, the incorrect toolchain
|
|
sysroot can be used in a multilib toolchain.
|
|
|
|
Therefore, let the user building OpenBLAS pass the appropriate -march
|
|
flag.
|
|
|
|
The other flags, such as -mfpu=vfp or -mfloat-abi=hard are kept, as they
|
|
are actually required for the build to proceed (OpenBLAS uses VFP
|
|
instructions, and assume an EABIhf ABI).
|
|
|
|
[Peter: update for v0.2.20]
|
|
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
|
|
---
|
|
Makefile.arm | 13 ++++---------
|
|
1 file changed, 4 insertions(+), 9 deletions(-)
|
|
|
|
diff --git a/Makefile.arm b/Makefile.arm
|
|
index eedd39b7..b5d80f8e 100644
|
|
--- a/Makefile.arm
|
|
+++ b/Makefile.arm
|
|
@@ -1,7 +1,7 @@
|
|
ifeq ($(CORE), $(filter $(CORE),ARMV7 CORTEXA9 CORTEXA15))
|
|
ifeq ($(OSNAME), Android)
|
|
-CCOMMON_OPT += -mfpu=neon -march=armv7-a
|
|
-FCOMMON_OPT += -mfpu=neon -march=armv7-a
|
|
+CCOMMON_OPT += -mfpu=neon
|
|
+FCOMMON_OPT += -mfpu=neon
|
|
else
|
|
CCOMMON_OPT += -mfpu=vfpv3 -march=armv7-a
|
|
FCOMMON_OPT += -mfpu=vfpv3 -march=armv7-a
|
|
@@ -9,11 +9,6 @@ endif
|
|
endif
|
|
|
|
ifeq ($(CORE), ARMV6)
|
|
-CCOMMON_OPT += -mfpu=vfp -march=armv6
|
|
-FCOMMON_OPT += -mfpu=vfp -march=armv6
|
|
-endif
|
|
-
|
|
-ifeq ($(CORE), ARMV5)
|
|
-CCOMMON_OPT += -march=armv5
|
|
-FCOMMON_OPT += -march=armv5
|
|
+CCOMMON_OPT += -mfpu=vfp
|
|
+FCOMMON_OPT += -mfpu=vfp
|
|
endif
|
|
--
|
|
2.11.0
|
|
|